sync ports with The Matrix

This commit is contained in:
purplerain 2023-10-06 03:46:28 +00:00
parent c5eac0c660
commit a9b47ea9ec
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
46 changed files with 112 additions and 30 deletions

0
audio/aqualung/files/aqualung.desktop Normal file → Executable file
View file

0
cad/fritzing/files/fritzing.desktop Normal file → Executable file
View file

0
devel/intellij/files/intellij-lightedit.desktop Normal file → Executable file
View file

0
devel/intellij/files/intellij.desktop Normal file → Executable file
View file

0
devel/netbeans/files/netbeans.desktop Normal file → Executable file
View file

0
devel/pycharm/files/pycharm-lightedit.desktop Normal file → Executable file
View file

0
devel/pycharm/files/pycharm.desktop Normal file → Executable file
View file

View file

@ -2,7 +2,7 @@ COMMENT = vi-like editor with sam-style structural regex support
V = 0.8
DISTNAME = vis-${V}
REVISION = 0
REVISION = 1
TEST_V = 0.5
TEST_DISTNAME = vis-test-${TEST_V}
@ -33,6 +33,7 @@ RUN_DEPENDS = devel/lpeg,${MODLUA_FLAVOR}>=0.12
TEST_DEPENDS = editors/vim
CONFIGURE_STYLE = simple
CONFIGURE_ENV = LUA_VER=${MODLUA_FLAVOR}
CONFIGURE_ARGS = --prefix=${PREFIX} \
--mandir=${PREFIX}/man

View file

@ -11,3 +11,12 @@ Index: configure
tryflag CFLAGS -ffunction-sections
tryflag CFLAGS -fdata-sections
tryldflag LDFLAGS_AUTO -Wl,--gc-sections
@@ -443,7 +442,7 @@ int main(int argc, char *argv[]) {
}
EOF
- for liblua in lua lua5.4 lua5.3 lua5.2 lua-5.3 lua-5.2 lua54 lua53 lua52; do
+ for liblua in $LUA_VER; do
printf " checking for %s... " "$liblua"
if test "$have_pkgconfig" = "yes" ; then

0
games/gnubg/files/gnubg.desktop Normal file → Executable file
View file

0
games/golly/files/golly.desktop Normal file → Executable file
View file

0
games/minecraft/files/minecraft.desktop Normal file → Executable file
View file

0
games/rocksndiamonds/files/rocksndiamonds.desktop Normal file → Executable file
View file

0
games/stone-soup/files/stone-soup.desktop Normal file → Executable file
View file

0
geo/josm/files/josm.desktop Normal file → Executable file
View file

0
graphics/pixelorama/files/pixelorama.desktop Normal file → Executable file
View file

View file

@ -6,7 +6,7 @@ DISTNAME = anthy-$V
PKGNAME-main = anthy-$V
PKGNAME-emacs = emacs-anthy-$V
REVISION-main = 3
REVISION-emacs = 8
REVISION-emacs = 9
SHARED_LIBS += anthydic 1.0 # .1.0
SHARED_LIBS += anthy 1.0 # .1.0

View file

@ -39,6 +39,24 @@ Index: src-util/anthy.el
(if anthy-xemacs
(if (coding-system-p (find-coding-system 'euc-japan))
(set-process-coding-system proc 'euc-japan 'euc-japan))
@@ -864,7 +864,7 @@
;; leim $B$N(B activate
;;
(defun anthy-leim-activate (&optional name)
- (setq inactivate-current-input-method-function 'anthy-leim-inactivate)
+ (setq deactivate-current-input-method-function 'anthy-leim-inactivate)
(setq anthy-leim-active-p t)
(anthy-update-mode)
(when (eq (selected-window) (minibuffer-window))
@@ -874,7 +874,7 @@
;; emacs$B$N%P%0Hr$1$i$7$$$G$9(B
;;
(defun anthy-leim-exit-from-minibuffer ()
- (inactivate-input-method)
+ (deactivate-input-method)
(when (<= (minibuffer-depth) 1)
(remove-hook 'minibuffer-exit-hook 'anthy-leim-exit-from-minibuffer)))
@@ -892,7 +892,7 @@
((event-matches-key-specifier-p event 'backspace) 8)
(t

0
lang/processing/files/processing.desktop Normal file → Executable file
View file

0
mail/mozilla-thunderbird/files/thunderbird.desktop Normal file → Executable file
View file

View file

@ -2,7 +2,7 @@ COMMENT= sendmail milter to scan messages for viruses and spam
DISTNAME= smtp-vilter-1.3.6
EPOCH= 0
REVISION= 6
REVISION= 7
CATEGORIES= mail
@ -14,6 +14,8 @@ WANTLIB += c m pthread milter
SITES= https://spacehopper.org/mirrors/
EXTRACT_SUFX= .tgz
FIX_EXTRACT_PERMISSIONS= Yes
LIB_DEPENDS= mail/sendmail,-libmilter
NO_TEST= Yes

View file

@ -1,7 +1,13 @@
Index: bin/smtp-vilter/Makefile
--- bin/smtp-vilter/Makefile.orig
+++ bin/smtp-vilter/Makefile
@@ -12,7 +12,7 @@ YFLAGS= -d -p vilter
@@ -7,12 +7,12 @@ SRCS= smtp-vilter.c engine.c imsg.c buffer.c pftable.
CFLAGS+= -pthread -Wall -I{.CURDIR} -I${.CURDIR}/../../include \
-I/usr/src/gnu/usr.sbin/sendmail/include
-LDADD+= -export-dynamic -lmilter -lpthread -L/usr/local/lib -lm
+LDADD+= -rdynamic -lmilter -lpthread -L/usr/local/lib -lm
YFLAGS= -d -p vilter
LFLAGS= -Pvilter -olex.yy.c
LINTFLAGS+= -u

View file

@ -1,5 +1,6 @@
--- bin/smtp-vilter/smtp-vilter.c.orig Sun Jan 21 13:09:38 2007
+++ bin/smtp-vilter/smtp-vilter.c Fri Oct 23 16:35:17 2009
Index: bin/smtp-vilter/smtp-vilter.c
--- bin/smtp-vilter/smtp-vilter.c.orig
+++ bin/smtp-vilter/smtp-vilter.c
@@ -22,6 +22,7 @@
#include <sys/resource.h>
#include <sys/stat.h>
@ -37,17 +38,30 @@
#endif
switch (ch) {
case 'A':
@@ -407,6 +410,13 @@ main(int argc, char *argv[])
break;
@@ -408,6 +411,13 @@ main(int argc, char *argv[])
case 'g':
group = optarg;
+ break;
break;
+ case 'H':
+ header_options = (unsigned long)strtonum(optarg, 0LL,
+ (long long)ULONG_MAX, &errstr);
+ if (errstr)
+ errx(1, "header options is %s: %s",
+ errstr, optarg);
break;
+ break;
#ifdef ENABLE_LDAP
case 'h':
ldaphost = optarg;
@@ -916,9 +926,10 @@ main(int argc, char *argv[])
time(&now);
if ((fp = fopen(statfile, "a")) !=
NULL) {
- fprintf(fp, "%u\t%u\t%u\t%u\t"
+ fprintf(fp, "%lld\t%lld\t%u\t%u\t"
"%u\t%u\t%u\t%u\t%u\n",
- stat_begin, now, n_conn,
+ (long long)stat_begin,
+ (long long)now, n_conn,
n_aborts, n_msgs,
n_virus, n_spam,
n_unwanted, n_err);

View file

@ -1,12 +1,13 @@
@newgroup _vilter:538
@newuser _vilter:538:538::smtp-vilter:/nonexistent:/sbin/nologin
@extraunexec rm -fr /var/smtp-vilter/*
@rcscript ${RCDIR}/smtp_vilter
lib/smtp-vilter/
lib/smtp-vilter/vilter-attachment.so
lib/smtp-vilter/vilter-clamd.so
lib/smtp-vilter/vilter-icap.so
lib/smtp-vilter/vilter-regex.so
lib/smtp-vilter/vilter-spamd.so
@so lib/smtp-vilter/vilter-attachment.so
@so lib/smtp-vilter/vilter-clamd.so
@so lib/smtp-vilter/vilter-icap.so
@so lib/smtp-vilter/vilter-regex.so
@so lib/smtp-vilter/vilter-spamd.so
@man man/man5/smtp-vilter.conf.5
@man man/man8/smtp-vilter.8
@bin sbin/smtp-vilter
@ -33,5 +34,3 @@ share/examples/smtp-vilter/spamd.conf
@sample /var/smtp-vilter/
@owner _vilter
@sample /var/smtp-vilter/tmp/
@owner
@rcscript ${RCDIR}/smtp_vilter

0
misc/wordnet/files/wordnet.desktop Normal file → Executable file
View file

0
net/unison/files/unison.desktop Normal file → Executable file
View file

0
textproc/mupdf/files/mupdf.desktop Normal file → Executable file
View file

0
www/chromium/files/chromium-browser.desktop Normal file → Executable file
View file

0
www/dillo/files/dillo.desktop Normal file → Executable file
View file

0
www/iridium/files/iridium-browser.desktop Normal file → Executable file
View file

View file

@ -1,3 +1,4 @@
NC_VERSION= 25.0.11
NC_VERSION= 25.0.12
REVISION= 1
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (nextcloud-25.0.11.tar.bz2) = UkOCknG6t9uN8ry3dGZ0y7DS3KlQu7mS5K6UO+N+rtE=
SIZE (nextcloud-25.0.11.tar.bz2) = 149674849
SHA256 (nextcloud-25.0.12.tar.bz2) = UgMYQkEdh7hjL47EEq14y0K9VIi+LT77/OSmhRykTYw=
SIZE (nextcloud-25.0.12.tar.bz2) = 149620447

View file

@ -0,0 +1,3 @@
This is an old major version of Nextcloud. Update to the newest available
in packages before updating to the next OpenBSD release.
See ${LOCALBASE}/share/doc/pkg-readmes/nextcloud for more information.

View file

@ -1,3 +1,4 @@
NC_VERSION= 26.0.7
REVISION= 0
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
This is an old major version of Nextcloud. Update to the newest available
in packages before updating to the next OpenBSD release.
See ${LOCALBASE}/share/doc/pkg-readmes/nextcloud for more information.

View file

@ -1,3 +1,4 @@
NC_VERSION= 27.1.1
REVISION= 0
.include <bsd.port.mk>

View file

@ -226,6 +226,16 @@ Updating
Before updating to a new release, read:
https://docs.nextcloud.com/server/${MAJOR}/admin_manual/maintenance/upgrade.html
To update from one major version to the next, "pkg_delete nextcloud"
and then "pkg_add nextcloud", choosing the next major version from
the list.
Nextcloud updates are only supported from one major version to the
next (23->24, 24->25, etc) and the release schedule does not align
nicely with OpenBSD's. To avoid an unsupported upgrade path, be sure
to update to the highest available Nextcloud major version before
upgrading to a new OpenBSD release.
WebDAV access
=============
The personal WebDAV share can be accessed using the following URL (e.g. with

View file

@ -44,6 +44,7 @@ PKGNAME-securelink= nginx-securelink-${VERSION}
REVISION-main= 0
REVISION-passenger= 1
REVISION-njs= 0
REVISION-lua= 0
ONLY_FOR_ARCHS-passenger= aarch64 amd64 arm i386
@ -97,7 +98,7 @@ WANTLIB-njs= exslt m xml2 xslt
WANTLIB-xslt= exslt xml2 xslt
WANTLIB-naxsi=
WANTLIB-ldap_auth= ldap
WANTLIB-lua= ${MODLUA_WANTLIB} m
WANTLIB-lua= ${MODLUA_WANTLIB} m pcre
WANTLIB-headers_more=
WANTLIB-perl= c m perl
WANTLIB-passenger= m pthread ${COMPILER_LIBCXX}
@ -109,7 +110,8 @@ LIB_DEPENDS-xslt= textproc/libxml \
LIB_DEPENDS-image_filter=graphics/gd
LIB_DEPENDS-geoip2= net/libmaxminddb
LIB_DEPENDS-ldap_auth= databases/openldap
LIB_DEPENDS-lua= ${MODLUA_LIB_DEPENDS}
LIB_DEPENDS-lua= ${MODLUA_LIB_DEPENDS} \
devel/pcre
LIB_DEPENDS-rtmp=
LIB_DEPENDS-securelink=
LIB_DEPENDS-njs= devel/pcre2 \
@ -120,7 +122,8 @@ MODLUA_RUNDEP= No
RUN_DEPENDS= www/nginx,-main=${VERSION}
RUN_DEPENDS-main= # blank (override default)
RUN_DEPENDS-lua= ${RUN_DEPENDS} \
${_MODLUA_RUN_DEPENDS}
${_MODLUA_RUN_DEPENDS} \
devel/pcre
RUN_DEPENDS-passenger= ${RUN_DEPENDS} \
ruby*-passenger-*:www/ruby-passenger

View file

@ -0,0 +1,11 @@
--- lua-nginx-module/config.orig Tue Oct 3 22:18:35 2023
+++ lua-nginx-module/config Tue Oct 3 22:21:42 2023
@@ -181,7 +181,7 @@
if [ $NGX_RPATH = YES ]; then
ngx_feature_libs="-R/usr/local/lib -L/usr/local/lib -llua -lm"
else
- ngx_feature_libs="-L/usr/local/lib -llua5.1 -lm"
+ ngx_feature_libs="-L/usr/local/lib -llua5.1 -lpcre -lm"
fi
. auto/feature
fi

0
www/seamonkey/files/seamonkey.desktop Normal file → Executable file
View file

0
www/tor-browser/browser/files/tor-browser.desktop Normal file → Executable file
View file

View file

@ -7,7 +7,7 @@ DPB_PROPERTIES= parallel parallel2
COMMENT= Chromium browser sans integration with Google
V= 117.0.5938.132
V= 117.0.5938.149
UGV= ${V}-1
DISTNAME= ungoogled-chromium-${V}

View file

@ -1,10 +1,10 @@
SHA256 (chromium-117.0.5938.132-testdata.tar.xz) = vCl+RGAfnZMgcj1xUynlPtafNoOTDtxWZxrGJrJCSOw=
SHA256 (chromium-117.0.5938.132.tar.xz) = KPB3EjpRlCg5qexRimSTDLwZIYbnme+Mze8ZyT3brq0=
SHA256 (chromium-117.0.5938.149-testdata.tar.xz) = OFrq6X5mpm7wrasDl1OKmdmsWcO7THFfY64UMc+4kkg=
SHA256 (chromium-117.0.5938.149.tar.xz) = 3dfIUr0ZHAkXq4AGVdo0HnWDwjd8oiCuB3/F3n/H2d8=
SHA256 (libudev-openbsd-20221108-c3330efd.tar.gz) = BBKUTWeCkarFwKZQ+eg9DfekIMr5xi2G4Lce0C43pnc=
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = osopYtr0gqj5QxY1QeHHO6SyaU+rzSUQmB8ttO2kk8g=
SHA256 (ungoogled-chromium-117.0.5938.132-1.tar.gz) = +Ye/gEp4cHt2Z2R23AfWFQjjasu1vZnwfWk0yCMQnZE=
SIZE (chromium-117.0.5938.132-testdata.tar.xz) = 269841680
SIZE (chromium-117.0.5938.132.tar.xz) = 3141005880
SHA256 (ungoogled-chromium-117.0.5938.149-1.tar.gz) = CvzB/vbhjGEueiXGXwi5jQ2z5iHID/hVy/1aeRtq0Do=
SIZE (chromium-117.0.5938.149-testdata.tar.xz) = 264315044
SIZE (chromium-117.0.5938.149.tar.xz) = 3141300340
SIZE (libudev-openbsd-20221108-c3330efd.tar.gz) = 32757
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
SIZE (ungoogled-chromium-117.0.5938.132-1.tar.gz) = 651922
SIZE (ungoogled-chromium-117.0.5938.149-1.tar.gz) = 651923

View file

0
x11/textsuggest/files/textsuggest-server.desktop Normal file → Executable file
View file

0
x11/xbindkeys/files/xbindkeys.desktop Normal file → Executable file
View file