ports/mail/smtp-vilter/patches/patch-bin_smtp-vilter_Makefile

25 lines
828 B
Text

Index: bin/smtp-vilter/Makefile
--- bin/smtp-vilter/Makefile.orig
+++ bin/smtp-vilter/Makefile
@@ -7,12 +7,12 @@ SRCS= smtp-vilter.c engine.c imsg.c buffer.c pftable.
CFLAGS+= -pthread -Wall -I{.CURDIR} -I${.CURDIR}/../../include \
-I/usr/src/gnu/usr.sbin/sendmail/include
-LDADD+= -export-dynamic -lmilter -lpthread -L/usr/local/lib -lm
+LDADD+= -rdynamic -lmilter -lpthread -L/usr/local/lib -lm
YFLAGS= -d -p vilter
LFLAGS= -Pvilter -olex.yy.c
LINTFLAGS+= -u
-CLEANFILES+= y.tab.h rt-dynamic
+CLEANFILES+= rt-dynamic
MAN= smtp-vilter.8 smtp-vilter.conf.5
MANDIR= /usr/local/man/cat
@@ -27,5 +27,5 @@ BINDIR= /usr/local/sbin
CFLAGS+= -I/usr/local/include -DENABLE_LDAP -DLDAP_DEPRECATED
.endif
.if defined(ENABLE_LDAP) || defined(WANT_LDAP)
-LDADD+= -lldap_r -llber
+LDADD+= -lldap -llber
.endif