UPDATE: lang/node 20.13.1 > 20.17.0

This commit is contained in:
purplerain 2024-09-19 07:08:57 +00:00
parent 84dc6ae727
commit 79a82efd93
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
15 changed files with 191 additions and 274 deletions

View file

@ -1,7 +1,7 @@
Index: Makefile
--- Makefile.orig
+++ Makefile
@@ -186,7 +186,7 @@ config.gypi: configure configure.py src/node_version.h
@@ -190,7 +190,7 @@ config.gypi: configure configure.py src/node_version.h
fi
.PHONY: install
@ -10,7 +10,7 @@ Index: Makefile
$(PYTHON) tools/install.py $@ --dest-dir '$(DESTDIR)' --prefix '$(PREFIX)'
.PHONY: uninstall
@@ -433,6 +433,12 @@ test/addons/.buildstamp: $(ADDONS_PREREQS) \
@@ -438,6 +438,12 @@ test/addons/.buildstamp: $(ADDONS_PREREQS) \
# Just goes to show that recursive make really is harmful...
# TODO(bnoordhuis) Force rebuild after gyp update.
build-addons: | $(NODE_EXE) test/addons/.buildstamp

View file

@ -1,7 +1,7 @@
Index: common.gypi
--- common.gypi.orig
+++ common.gypi
@@ -189,7 +189,6 @@
@@ -190,7 +190,6 @@
}],
],
},
@ -9,7 +9,7 @@ Index: common.gypi
'conditions': [
['enable_lto=="true"', {
'cflags': ['<(lto)'],
@@ -473,7 +472,9 @@
@@ -474,7 +473,9 @@
}],
['OS=="openbsd"', {
'cflags': [ '-I/usr/local/include' ],
@ -20,7 +20,7 @@ Index: common.gypi
}],
['_toolset=="host"', {
'conditions': [
@@ -490,7 +491,7 @@
@@ -491,7 +492,7 @@
'ldflags': [ '-m32' ],
}],
[ 'host_arch=="ppc64" and OS not in "aix os400"', {
@ -29,7 +29,7 @@ Index: common.gypi
'ldflags': [ '-m64' ],
}],
[ 'host_arch=="s390x" and OS=="linux"', {
@@ -514,7 +515,7 @@
@@ -515,7 +516,7 @@
'ldflags': [ '-m32' ],
}],
[ 'target_arch=="ppc64" and OS not in "aix os400"', {

View file

@ -1,10 +1,11 @@
Index: configure
--- configure.orig
+++ configure
@@ -4,13 +4,6 @@
@@ -4,14 +4,6 @@
# Note that the mix of single and double quotes is intentional,
# as is the fact that the ] goes on a new line.
_=[ 'exec' '/bin/sh' '-c' '''
-command -v python3.13 >/dev/null && exec python3.13 "$0" "$@"
-command -v python3.12 >/dev/null && exec python3.12 "$0" "$@"
-command -v python3.11 >/dev/null && exec python3.11 "$0" "$@"
-command -v python3.10 >/dev/null && exec python3.10 "$0" "$@"

View file

@ -1,7 +1,7 @@
Index: configure.py
--- configure.py.orig
+++ configure.py
@@ -1540,6 +1540,10 @@ def configure_v8(o):
@@ -1599,6 +1599,10 @@ def configure_v8(o):
raise Exception(
'Only one of the --v8-enable-object-print or --v8-disable-object-print options '
'can be specified at a time.')

View file

@ -1,7 +1,7 @@
Index: deps/ada/ada.cpp
--- deps/ada/ada.cpp.orig
+++ deps/ada/ada.cpp
@@ -10485,7 +10485,7 @@ ada_unused std::string get_state(ada::state s) {
@@ -10486,7 +10486,7 @@ ada_unused std::string get_state(ada::state s) {
return "Special Authority Slashes";
case ada::state::SPECIAL_RELATIVE_OR_AUTHORITY:
return "Special Relative or Authority";
@ -10,7 +10,7 @@ Index: deps/ada/ada.cpp
return "Query";
case ada::state::PATH:
return "Path";
@@ -12573,7 +12573,7 @@ result_type parse_url(std::string_view user_input,
@@ -12575,7 +12575,7 @@ result_type parse_url_impl(std::string_view user_input
// state to query state.
if ((input_position != input_size) &&
(url_data[input_position] == '?')) {
@ -19,16 +19,16 @@ Index: deps/ada/ada.cpp
}
// Otherwise, if c is not the EOF code point:
else if (input_position != input_size) {
@@ -12668,7 +12668,7 @@ result_type parse_url(std::string_view user_input,
@@ -12670,7 +12670,7 @@ result_type parse_url_impl(std::string_view user_input
break;
}
- case ada::state::QUERY: {
+ case ada::state::ADAQUERY: {
ada_log("QUERY ", helpers::substring(url_data, input_position));
// Let queryPercentEncodeSet be the special-query percent-encode set if
// url is special; otherwise the query percent-encode set.
@@ -12750,7 +12750,7 @@ result_type parse_url(std::string_view user_input,
if constexpr (store_values) {
// Let queryPercentEncodeSet be the special-query percent-encode set
@@ -12755,7 +12755,7 @@ result_type parse_url_impl(std::string_view user_input
size_t location = view.find('?');
if (location != std::string_view::npos) {
view.remove_suffix(view.size() - location);
@ -37,7 +37,7 @@ Index: deps/ada/ada.cpp
input_position += location + 1;
} else {
input_position = input_size + 1;
@@ -12803,7 +12803,7 @@ result_type parse_url(std::string_view user_input,
@@ -12810,7 +12810,7 @@ result_type parse_url_impl(std::string_view user_input
// set url's query to the empty string and state to query state.
else if ((input_position != input_size) &&
(url_data[input_position] == '?')) {
@ -46,7 +46,7 @@ Index: deps/ada/ada.cpp
}
// Otherwise, if c is not the EOF code point:
else if (input_position != input_size) {
@@ -12827,7 +12827,7 @@ result_type parse_url(std::string_view user_input,
@@ -12834,7 +12834,7 @@ result_type parse_url_impl(std::string_view user_input
// Furthermore, we can immediately locate the '?'.
size_t locofquestionmark = view.find('?');
if (locofquestionmark != std::string_view::npos) {
@ -55,7 +55,7 @@ Index: deps/ada/ada.cpp
view.remove_suffix(view.size() - locofquestionmark);
input_position += locofquestionmark + 1;
} else {
@@ -12987,7 +12987,7 @@ result_type parse_url(std::string_view user_input,
@@ -12996,7 +12996,7 @@ result_type parse_url_impl(std::string_view user_input
// If c is U+003F (?), then set url's query to the empty string and
// state to query state.
if (input_position != input_size && url_data[input_position] == '?') {

View file

@ -1,12 +1,12 @@
Index: deps/ada/ada.h
--- deps/ada/ada.h.orig
+++ deps/ada/ada.h
@@ -1229,7 +1229,7 @@ enum class state {
SPECIAL_AUTHORITY_IGNORE_SLASHES,
SPECIAL_AUTHORITY_SLASHES,
SPECIAL_RELATIVE_OR_AUTHORITY,
@@ -1292,7 +1292,7 @@ enum class state {
/**
* @see https://url.spec.whatwg.org/#query-state
*/
- QUERY,
+ ADAQUERY,
PATH,
PATH_START,
OPAQUE_PATH,
/**
* @see https://url.spec.whatwg.org/#path-state

View file

@ -1,7 +1,7 @@
Index: include/node/common.gypi
--- include/node/common.gypi.orig
+++ include/node/common.gypi
@@ -189,7 +189,6 @@
@@ -190,7 +190,6 @@
}],
],
},
@ -9,7 +9,7 @@ Index: include/node/common.gypi
'conditions': [
['enable_lto=="true"', {
'cflags': ['<(lto)'],
@@ -490,7 +489,7 @@
@@ -491,7 +490,7 @@
'ldflags': [ '-m32' ],
}],
[ 'host_arch=="ppc64" and OS not in "aix os400"', {
@ -18,7 +18,7 @@ Index: include/node/common.gypi
'ldflags': [ '-m64' ],
}],
[ 'host_arch=="s390x" and OS=="linux"', {
@@ -514,7 +513,7 @@
@@ -515,7 +514,7 @@
'ldflags': [ '-m32' ],
}],
[ 'target_arch=="ppc64" and OS not in "aix os400"', {

View file

@ -1,7 +1,7 @@
Index: lib/internal/modules/cjs/loader.js
--- lib/internal/modules/cjs/loader.js.orig
+++ lib/internal/modules/cjs/loader.js
@@ -1518,7 +1518,10 @@ Module._initPaths = function() {
@@ -1650,7 +1650,10 @@ Module._initPaths = function() {
path.resolve(process.execPath, '..') :
path.resolve(process.execPath, '..', '..');

View file

@ -13,7 +13,7 @@ for "any address" but that's not really a straightforward change).
Index: lib/net.js
--- lib/net.js.orig
+++ lib/net.js
@@ -1860,22 +1860,12 @@ function setupListenHandle(address, port, addressType,
@@ -1861,22 +1861,12 @@ function setupListenHandle(address, port, addressType,
let rval = null;

View file

@ -4,7 +4,7 @@ devel/gtest if installed.
Index: node.gyp
--- node.gyp.orig
+++ node.gyp
@@ -826,7 +826,7 @@
@@ -828,7 +828,7 @@
],
'dependencies': [
'deps/base64/base64.gyp:base64',
@ -13,7 +13,7 @@ Index: node.gyp
'deps/histogram/histogram.gyp:histogram',
'deps/uvwasi/uvwasi.gyp:uvwasi',
'deps/simdutf/simdutf.gyp:simdutf',
@@ -1056,8 +1056,8 @@
@@ -1146,8 +1146,8 @@
'dependencies': [
'<(node_lib_target_name)',
'deps/base64/base64.gyp:base64',
@ -24,7 +24,7 @@ Index: node.gyp
'deps/histogram/histogram.gyp:histogram',
'deps/uvwasi/uvwasi.gyp:uvwasi',
'deps/simdutf/simdutf.gyp:simdutf',
@@ -1105,6 +1105,10 @@
@@ -1195,6 +1195,10 @@
}],
['OS=="solaris"', {
'ldflags': [ '-I<(SHARED_INTERMEDIATE_DIR)' ]

View file

@ -1,7 +1,7 @@
Index: src/env.cc
--- src/env.cc.orig
+++ src/env.cc
@@ -745,29 +745,7 @@ std::unique_ptr<v8::BackingStore> Environment::release
@@ -757,29 +757,7 @@ std::unique_ptr<v8::BackingStore> Environment::release
}
std::string Environment::GetExecPath(const std::vector<std::string>& argv) {

View file

@ -1,7 +1,7 @@
Index: tools/test.py
--- tools/test.py.orig
+++ tools/test.py
@@ -944,9 +944,9 @@ class Context(object):
@@ -962,9 +962,9 @@ class Context(object):
if self.vm is not None:
return self.vm
if arch == 'none':