ports/lang/node/patches/patch-Makefile

25 lines
984 B
Text

Index: Makefile
--- Makefile.orig
+++ Makefile
@@ -190,7 +190,7 @@ config.gypi: configure configure.py src/node_version.h
fi
.PHONY: install
-install: all ## Installs node into $PREFIX (default=/usr/local).
+install: all build-pledge ## Installs node into $PREFIX (default=/usr/local).
$(PYTHON) tools/install.py $@ --dest-dir '$(DESTDIR)' --prefix '$(PREFIX)'
.PHONY: uninstall
@@ -438,6 +438,12 @@ test/addons/.buildstamp: $(ADDONS_PREREQS) \
# Just goes to show that recursive make really is harmful...
# TODO(bnoordhuis) Force rebuild after gyp update.
build-addons: | $(NODE_EXE) test/addons/.buildstamp
+
+build-pledge: $(NODE_EXE)
+ $(NODE) deps/npm/node_modules/node-gyp/bin/node-gyp.js rebuild \
+ --directory="deps/npm/node_modules/node-pledge" \
+ --nodedir="$(shell pwd)" && \
+ $(RM) -rf deps/npm/node_modules/node-pledge/build/Release/{.deps,../Makefile,obj.target}
JS_NATIVE_API_BINDING_GYPS := \
$(filter-out test/js-native-api/??_*/binding.gyp, \