SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
15
net/srain/patches/patch-src_Makefile
Normal file
15
net/srain/patches/patch-src_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
Don't hardcode -O2.
|
||||
This is actually C11 according to clang.
|
||||
|
||||
Index: src/Makefile
|
||||
--- src/Makefile.orig
|
||||
+++ src/Makefile
|
||||
@@ -29,7 +29,7 @@ LIBSSLLIBS = $(shell pkg-config --libs openssl)
|
||||
LIBSECRETFLAGS =$(shell pkg-config --cflags libsecret-1)
|
||||
LIBSECRETLIBS =$(shell pkg-config --libs libsecret-1)
|
||||
|
||||
-CFLAGS += -std=gnu99 -O2 -Wall -Iinc -Wno-deprecated-declarations \
|
||||
+CFLAGS += -std=gnu11 -Wall -Iinc -Wno-deprecated-declarations \
|
||||
$(DEFS) \
|
||||
$(DBGFLAGS) \
|
||||
$(GTK3FLAGS) \
|
Loading…
Add table
Add a link
Reference in a new issue