ports/archivers/minizip/patches/patch-CMakeLists_txt

15 lines
448 B
Text

CMake: Fix build with OpenBSD #711
57be074f6f300fcacd361f52dea62874c7214084
Index: CMakeLists.txt
--- CMakeLists.txt.orig
+++ CMakeLists.txt
@@ -455,7 +455,7 @@ if(WIN32)
set(MZ_LIBBSD OFF)
set(MZ_ICONV OFF)
else()
- list(APPEND STDLIB_DEF -D_POSIX_C_SOURCE=200809L)
+ list(APPEND STDLIB_DEF -D_POSIX_C_SOURCE=200809L -D_BSD_SOURCE)
list(APPEND MINIZIP_SRC mz_os_posix.c mz_strm_os_posix.c)
if(MZ_PKCRYPT OR MZ_WZAES)