70 lines
2.8 KiB
Text
70 lines
2.8 KiB
Text
Index: libs.mk
|
|
--- libs.mk.orig
|
|
+++ libs.mk
|
|
@@ -336,22 +336,17 @@ EXPORT_FILE := libvpx.def
|
|
LIBVPX_SO_SYMLINKS :=
|
|
LIBVPX_SO_IMPLIB := libvpx_dll.a
|
|
else
|
|
-LIBVPX_SO := libvpx.so.$(SO_VERSION_MAJOR).$(SO_VERSION_MINOR).$(SO_VERSION_PATCH)
|
|
+LIBVPX_SO := libvpx.so.$(LIBVPX_VERSION)
|
|
SHARED_LIB_SUF := .so
|
|
EXPORT_FILE := libvpx.ver
|
|
-LIBVPX_SO_SYMLINKS := $(addprefix $(LIBSUBDIR)/, \
|
|
- libvpx.so libvpx.so.$(SO_VERSION_MAJOR) \
|
|
- libvpx.so.$(SO_VERSION_MAJOR).$(SO_VERSION_MINOR))
|
|
endif
|
|
endif
|
|
endif
|
|
|
|
LIBS-$(CONFIG_SHARED) += $(BUILD_PFX)$(LIBVPX_SO)\
|
|
- $(notdir $(LIBVPX_SO_SYMLINKS)) \
|
|
$(if $(LIBVPX_SO_IMPLIB), $(BUILD_PFX)$(LIBVPX_SO_IMPLIB))
|
|
$(BUILD_PFX)$(LIBVPX_SO): $(LIBVPX_OBJS) $(EXPORT_FILE)
|
|
$(BUILD_PFX)$(LIBVPX_SO): extralibs += -lm
|
|
-$(BUILD_PFX)$(LIBVPX_SO): SONAME = libvpx.so.$(SO_VERSION_MAJOR)
|
|
$(BUILD_PFX)$(LIBVPX_SO): EXPORTS_FILE = $(EXPORT_FILE)
|
|
|
|
libvpx.def: $(call enabled,CODEC_EXPORTS)
|
|
@@ -374,15 +369,7 @@ $(1): $(2)
|
|
$(qexec)ln -sf $(2) $$@
|
|
endef
|
|
|
|
-$(eval $(call libvpx_symlink_template,\
|
|
- $(addprefix $(BUILD_PFX),$(notdir $(LIBVPX_SO_SYMLINKS))),\
|
|
- $(BUILD_PFX)$(LIBVPX_SO)))
|
|
-$(eval $(call libvpx_symlink_template,\
|
|
- $(addprefix $(DIST_DIR)/,$(LIBVPX_SO_SYMLINKS)),\
|
|
- $(LIBVPX_SO)))
|
|
|
|
-
|
|
-INSTALL-LIBS-$(CONFIG_SHARED) += $(LIBVPX_SO_SYMLINKS)
|
|
INSTALL-LIBS-$(CONFIG_SHARED) += $(LIBSUBDIR)/$(LIBVPX_SO)
|
|
INSTALL-LIBS-$(CONFIG_SHARED) += $(if $(LIBVPX_SO_IMPLIB),$(LIBSUBDIR)/$(LIBVPX_SO_IMPLIB))
|
|
|
|
@@ -545,7 +532,7 @@ testdata: $(LIBVPX_TEST_DATA)
|
|
set -e;\
|
|
echo "Checking test data:";\
|
|
for f in $(call enabled,LIBVPX_TEST_DATA); do\
|
|
- grep $$f $(SRC_PATH_BARE)/test/test-data.sha1 |\
|
|
+ grep $$f $(SRC_PATH_BARE)/test/test-data.sha1 | tr -d '*' |\
|
|
(cd "$(LIBVPX_TEST_DATA_PATH)"; $${sha1sum} -c);\
|
|
done; \
|
|
else\
|
|
@@ -657,7 +644,7 @@ BINS-yes += $(LIBVPX_TEST_BIN)
|
|
|
|
CODEC_LIB=$(if $(CONFIG_DEBUG_LIBS),vpx_g,vpx)
|
|
CODEC_LIB_SUF=$(if $(CONFIG_SHARED),$(SHARED_LIB_SUF),.a)
|
|
-TEST_LIBS := lib$(CODEC_LIB)$(CODEC_LIB_SUF) libgtest.a
|
|
+TEST_LIBS := lib$(CODEC_LIB)$(CODEC_LIB_SUF).$(LIBVPX_VERSION) libgtest.a
|
|
$(LIBVPX_TEST_BIN): $(TEST_LIBS)
|
|
$(eval $(call linkerxx_template,$(LIBVPX_TEST_BIN), \
|
|
$(LIBVPX_TEST_OBJS) \
|
|
@@ -716,6 +703,8 @@ test_shard.$(1) test_shard_ndc.$(1): $(LIBVPX_TEST_BIN
|
|
@set -e; \
|
|
export GTEST_SHARD_INDEX=$(1); \
|
|
export GTEST_TOTAL_SHARDS=$(2); \
|
|
+ export LIBVPX_TEST_DATA_PATH=$(LIBVPX_TEST_DATA_PATH); \
|
|
+ export LD_LIBRARY_PATH=$(CURDIR); \
|
|
$(LIBVPX_TEST_BIN)
|
|
test_shard.$(1): testdata
|
|
.PHONY: test_shard.$(1) test_shard_ndc.$(1)
|