242 lines
8.1 KiB
Text
242 lines
8.1 KiB
Text
Index: gcc/ada/Makefile.rtl
|
|
--- gcc/ada/Makefile.rtl.orig
|
|
+++ gcc/ada/Makefile.rtl
|
|
@@ -1873,6 +1873,229 @@ ifeq ($(strip $(filter-out x86_64 kfreebsd%,$(target_c
|
|
LIBRARY_VERSION := $(LIB_VERSION)
|
|
endif
|
|
|
|
+ifeq ($(strip $(filter-out arm openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(ATOMICS_BUILTINS_TARGET_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-arm.ads
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out %86 openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(X86_TARGET_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-x86.ads
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out %86_64 openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(X86_64_TARGET_PAIRS) \
|
|
+ $(GNATRTL_128BIT_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-x86_64.ads
|
|
+
|
|
+ EXTRA_GNATRTL_NONTASKING_OBJS = $(GNATRTL_128BIT_OBJS)
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out sparc64 openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(ATOMICS_BUILTINS_TARGET_PAIRS) \
|
|
+ $(GNATRTL_128BIT_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-sparcv9.ads
|
|
+
|
|
+ EXTRA_GNATRTL_NONTASKING_OBJS = $(GNATRTL_128BIT_OBJS)
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out powerpc openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(ATOMICS_BUILTINS_TARGET_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-ppc.ads
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out mips64 openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(GNATRTL_128BIT_PAIRS) \
|
|
+ $(ATOMICS_BUILTINS_TARGET_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-mips64.ads
|
|
+
|
|
+ EXTRA_GNATRTL_NONTASKING_OBJS = $(GNATRTL_128BIT_OBJS)
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out mips64el openbsd%,$(target_cpu) $(target_os))),)
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(ATOMICS_BUILTINS_TARGET_PAIRS) \
|
|
+ $(GNATRTL_128BIT_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-mips64el.ads
|
|
+
|
|
+ EXTRA_GNATRTL_NONTASKING_OBJS = $(GNATRTL_128BIT_OBJS)
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
+ifeq ($(strip $(filter-out hppa openbsd%,$(target_cpu) $(target_os))),)
|
|
+ ATOMICS_BUILTINS_TARGET_PAIRS = \
|
|
+ s-atocou.adb<libgnat/s-atocou.adb
|
|
+
|
|
+ LIBGNAT_TARGET_PAIRS = \
|
|
+ a-intnam.ads<libgnarl/a-intnam__freebsd.ads \
|
|
+ s-inmaop.adb<libgnarl/s-inmaop__posix.adb \
|
|
+ s-intman.adb<libgnarl/s-intman__posix.adb \
|
|
+ s-osinte.ads<libgnarl/s-osinte__openbsd.ads \
|
|
+ s-osinte.adb<libgnarl/s-osinte__openbsd.adb \
|
|
+ s-osprim.adb<libgnat/s-osprim__posix.adb \
|
|
+ s-taprop.adb<libgnarl/s-taprop__posix.adb \
|
|
+ s-taspri.ads<libgnarl/s-taspri__posix.ads \
|
|
+ s-tpopsp.adb<libgnarl/s-tpopsp__posix.adb \
|
|
+ $(ATOMICS_TARGET_PAIRS) \
|
|
+ $(ATOMICS_BUILTINS_TARGET_PAIRS) \
|
|
+ system.ads<libgnat/system-openbsd-hppa.ads
|
|
+
|
|
+ TOOLS_TARGET_PAIRS = \
|
|
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
|
|
+ GNATLIB_SHARED = gnatlib-shared-dual
|
|
+
|
|
+ EH_MECHANISM=-gcc
|
|
+ THREADSLIB= -lpthread
|
|
+ GMEM_LIB = gmemlib
|
|
+ LIBRARY_VERSION := $(LIB_VERSION)
|
|
+ MISCLIB = -lutil
|
|
+endif
|
|
+
|
|
# aarch64 FreeBSD
|
|
ifeq ($(strip $(filter-out %aarch64 freebsd%,$(target_cpu) $(target_os))),)
|
|
LIBGNAT_TARGET_PAIRS = \
|
|
@@ -2953,7 +3176,7 @@ LIBGNAT_OBJS = adadecode.o adaint.o argv.o aux-io.o
|
|
# from ADA_INCLUDE_SRCS.
|
|
|
|
LIBGNAT_SRCS = $(patsubst %.o,%.c,$(LIBGNAT_OBJS)) \
|
|
- adadecode.h adaint.h env.h gsocket.h raise.h standard.ads.h \
|
|
+ adadecode.h adaint.h env.h gsocket.h raise.h \
|
|
runtime.h $(EXTRA_LIBGNAT_SRCS)
|
|
|
|
# memtrack.o is special as not put into libgnat.
|