ports/graphics/feh/patches/patch-config_mk

18 lines
492 B
Text

zap redundant CFLAGS
fix "filelist.c:253:45: error: use of undeclared identifier 'alphasort'"
Index: config.mk
--- config.mk.orig
+++ config.mk
@@ -37,10 +37,6 @@ scalable_icon_dir = ${icon_dir}/scalable/apps
# default CFLAGS
CFLAGS ?= -g -O2
-CFLAGS += -Wall -Wextra -pedantic
-
-# Settings for glibc >= 2.19 - may need to be adjusted for other systems
-CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -D_DARWIN_C_SOURCE
ifeq (${curl},1)
CFLAGS += -DHAVE_LIBCURL