ports/www/py-bokeh/patches/patch-pyproject_toml

25 lines
682 B
Text

Index: pyproject.toml
--- pyproject.toml.orig
+++ pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools>=64", "setuptools-git-versioning", "colorama"]
+requires = ["setuptools>=64"]
build-backend = "setuptools.build_meta"
[project]
@@ -65,14 +65,8 @@ bokeh = "bokeh.__main__:main"
[tool.setuptools.packages.find]
where = ["src"]
-[tool.setuptools-git-versioning]
-enabled = true
-dev_template = "{tag}+{ccount}.g{sha}"
-dirty_template = "{tag}+{ccount}.g{sha}.dirty"
-
[tool.pytest.ini_options]
timeout = 60
-asyncio_mode = "strict"
norecursedirs = "build _build node_modules tests/support"
python_files = "*_tests.py *_test.py test_*.py"
markers = [