14 lines
627 B
Text
14 lines
627 B
Text
Link nix against libboost_{context,thread}-mt and libc.
|
|
|
|
Index: src/nix/local.mk
|
|
--- src/nix/local.mk.orig
|
|
+++ src/nix/local.mk
|
|
@@ -17,7 +17,7 @@ nix_SOURCES := \
|
|
|
|
nix_LIBS = libexpr libmain libstore libutil
|
|
|
|
-nix_LDFLAGS = -pthread $(SODIUM_LIBS) $(EDITLINE_LIBS) $(BOOST_LDFLAGS) -lboost_context -lboost_thread -lboost_system
|
|
+nix_LDFLAGS = -pthread $(SODIUM_LIBS) $(EDITLINE_LIBS) $(BOOST_LDFLAGS) -lboost_context-mt -lboost_thread-mt -lboost_system -lc
|
|
|
|
$(foreach name, \
|
|
nix-build nix-channel nix-collect-garbage nix-copy-closure nix-daemon nix-env nix-hash nix-instantiate nix-prefetch-url nix-shell nix-store, \
|