ports/math/mcsim/patches/patch-mod_Makefile

29 lines
748 B
Text

--- mod/Makefile.orig Thu Mar 6 17:14:37 1997
+++ mod/Makefile Wed Mar 14 23:21:47 2001
@@ -97,8 +97,8 @@ MOD = mod
#
#>>>> Define the COMPILER name and LINKER name here only.
-CC = gcc
-LINK = gcc
+#CC =
+LINK = $(CC)
#>>>> Define PATHS
# The include path should be a directory containing header
@@ -143,13 +143,13 @@ L_OPTIM_FLAG =
#
#>>>> Include any special warning flags
#
-WARNINGS = -Wall
+WARNINGS = -ansi
#--------------------
#**** You shouldn't need to change these lines. They are dependent
#**** only on the above setup.
-CFLAGS = $(C_OPTIM_FLAG) $(C_DEBUG_FLAG) $(DEBUG_SYMBOLS) \
+CFLAGS += $(C_DEBUG_FLAG) $(DEBUG_SYMBOLS) \
-I $(INCPATH) $(WARNINGS) -DMODGEN
CLFLAGS = $(L_OPTIM_FLAG) $(L_DEBUG_FLAG)