ports/sysutils/cdrtools/patches/patch-cdda2wav_configure_in

54 lines
1.2 KiB
Text

--- cdda2wav/configure.in.orig Sat Aug 8 21:40:53 2009
+++ cdda2wav/configure.in Thu Oct 30 19:15:57 2014
@@ -19,15 +19,32 @@ case "$host_os" in
AC_CHECK_LIB(posix4, sched_get_priority_max)
;;
esac
+case "$host_os" in
+ *openbsd*)
+dnl skip obsolete libossaudio on OpenBSD
+;;
+ *)
AC_CHECK_LIB(ossaudio, _oss_ioctl)
+;;
+esac
+AC_CHECK_LIB(sndio, sio_open)
EXTRALIBS="$LIBS"
AC_SUBST(EXTRALIBS)
dnl check header files
-AC_CHECK_HEADERS(sys/cdio.h sys/cdrio.h sundev/srreg.h sys/audioio.h sun/audioio.h)
+AC_CHECK_HEADERS(sndio.h)
+AC_CHECK_HEADERS(sys/cdio.h sys/cdrio.h sundev/srreg.h)
+case "$host_os" in
+ *openbsd*)
+dnl skip obsolete soundcard.h and non-SunOS-compatible audioio.h on OpenBSD
+;;
+ *)
+AC_CHECK_HEADERS(sys/audioio.h sun/audioio.h)
AC_CHECK_HEADERS(soundcard.h sys/soundcard.h linux/soundcard.h machine/soundcard.h)
+;;
+esac
dnl We no longer include HAVE_WINDOWS_H in lconfig.h but we need the test
dnl result together with the test for mmsystem.h
AC_CHECK_HEADERS(sys/asoundlib.h windows.h mmsystem.h)
@@ -61,6 +78,17 @@ HAVE_OSS=
;;
esac
AC_SUBST(HAVE_OSS)
+
+case "${ac_cv_header_sndio_h}" in
+ *yes*)
+HAVE_SNDIO=1
+;;
+ *)
+HAVE_SNDIO=
+;;
+esac
+AC_SUBST(HAVE_SNDIO)
+
AC_SUBST(HAVE_SYS_ASOUNDLIB_H)