35 lines
1.6 KiB
Text
35 lines
1.6 KiB
Text
Don't rely on gmake for this Makefile which is installed for the user
|
|
to generate their own certificates.
|
|
|
|
Index: raddb/certs/Makefile
|
|
--- raddb/certs/Makefile.orig
|
|
+++ raddb/certs/Makefile
|
|
@@ -20,7 +20,12 @@ endif
|
|
#
|
|
# Set the passwords
|
|
#
|
|
-include passwords.mk
|
|
+PASSWORD_SERVER!= grep output_password server.cnf | sed 's/.*=//;s/^ *//'
|
|
+PASSWORD_INNER!= grep output_password inner-server.cnf | sed 's/.*=//;s/^ *//'
|
|
+PASSWORD_CA!= grep output_password ca.cnf | sed 's/.*=//;s/^ *//'
|
|
+PASSWORD_CLIENT!= grep output_password client.cnf | sed 's/.*=//;s/^ *//'
|
|
+USER_NAME!= grep emailAddress client.cnf | grep '@' | sed 's/.*=//;s/^ *//'
|
|
+CA_DEFAULT_DAYS!= grep default_days ca.cnf | sed 's/.*=//;s/^ *//'
|
|
|
|
######################################################################
|
|
#
|
|
@@ -44,14 +49,6 @@ inner-server: inner-server.pem inner-server.vrfy
|
|
|
|
.PHONY: verify
|
|
verify: server.vrfy client.vrfy
|
|
-
|
|
-passwords.mk: server.cnf ca.cnf client.cnf inner-server.cnf
|
|
- @echo "PASSWORD_SERVER = '$(shell grep output_password server.cnf | sed 's/.*=//;s/^ *//')'" > $@
|
|
- @echo "PASSWORD_INNER = '$(shell grep output_password inner-server.cnf | sed 's/.*=//;s/^ *//')'" >> $@
|
|
- @echo "PASSWORD_CA = '$(shell grep output_password ca.cnf | sed 's/.*=//;s/^ *//')'" >> $@
|
|
- @echo "PASSWORD_CLIENT = '$(shell grep output_password client.cnf | sed 's/.*=//;s/^ *//')'" >> $@
|
|
- @echo "USER_NAME = '$(shell grep emailAddress client.cnf | grep '@' | sed 's/.*=//;s/^ *//')'" >> $@
|
|
- @echo "CA_DEFAULT_DAYS = '$(shell grep default_days ca.cnf | sed 's/.*=//;s/^ *//')'" >> $@
|
|
|
|
######################################################################
|
|
#
|