16 lines
526 B
Text
16 lines
526 B
Text
drop -std=c89, fails with clang 13
|
|
|
|
cf https://github.com/MapServer/mapcache/pull/290#issuecomment-1410089296
|
|
|
|
Index: CMakeLists.txt
|
|
--- CMakeLists.txt.orig
|
|
+++ CMakeLists.txt
|
|
@@ -82,7 +82,7 @@ if(CMAKE_COMPILER_IS_GNUCC)
|
|
endif()
|
|
|
|
if(CMAKE_C_COMPILER_ID MATCHES "Clang")
|
|
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror=declaration-after-statement -std=c89 -Wno-comment")
|
|
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror=declaration-after-statement -Wno-comment")
|
|
endif()
|
|
|
|
#options suported by the cmake builder
|