22 lines
944 B
Text
22 lines
944 B
Text
Index: setup.py
|
|
--- setup.py.orig
|
|
+++ setup.py
|
|
@@ -61,16 +61,15 @@ else:
|
|
storage_dirs = [ ('storage/ceres/dummy.txt', []), ('storage/whisper/dummy.txt',[]),
|
|
('storage/lists',[]), ('storage/log/dummy.txt',[]),
|
|
('storage/rrd/dummy.txt',[]) ]
|
|
-conf_files = [ ('conf', glob('conf/*.example')) ]
|
|
+conf_files = [ ('${GRAPHITE_EGDIR}', glob('conf/*.example')) ]
|
|
|
|
-install_files = storage_dirs + conf_files
|
|
+install_files = conf_files
|
|
|
|
# Let's include redhat init scripts, despite build platform
|
|
# but won't put them in /etc/init.d/ automatically anymore
|
|
init_scripts = [ ('examples/init.d', ['distro/redhat/init.d/carbon-cache',
|
|
'distro/redhat/init.d/carbon-relay',
|
|
'distro/redhat/init.d/carbon-aggregator']) ]
|
|
-install_files += init_scripts
|
|
|
|
def read(fname):
|
|
with open(os.path.join(os.path.dirname(__file__), fname)) as f:
|