23 lines
835 B
Text
23 lines
835 B
Text
Some compilers don't have -Wvla.
|
|
|
|
Index: lib/libzstd.mk
|
|
--- lib/libzstd.mk.orig
|
|
+++ lib/libzstd.mk
|
|
@@ -100,7 +100,7 @@ endif
|
|
DEBUGFLAGS= -Wall -Wextra -Wcast-qual -Wcast-align -Wshadow \
|
|
-Wstrict-aliasing=1 -Wswitch-enum -Wdeclaration-after-statement \
|
|
-Wstrict-prototypes -Wundef -Wpointer-arith \
|
|
- -Wvla -Wformat=2 -Winit-self -Wfloat-equal -Wwrite-strings \
|
|
+ -Wformat=2 -Winit-self -Wfloat-equal -Wwrite-strings \
|
|
-Wredundant-decls -Wmissing-prototypes -Wc++-compat
|
|
CFLAGS += $(DEBUGFLAGS) $(MOREFLAGS)
|
|
ASFLAGS += $(DEBUGFLAGS) $(MOREFLAGS) $(CFLAGS)
|
|
@@ -197,6 +197,8 @@ else ifeq ($(UNAME), FreeBSD)
|
|
else ifeq ($(UNAME), NetBSD)
|
|
HASH ?= md5 -n
|
|
else ifeq ($(UNAME), OpenBSD)
|
|
+ HASH ?= md5
|
|
+else ifeq ($(UNAME), SecBSD)
|
|
HASH ?= md5
|
|
endif
|
|
HASH ?= md5sum
|