ports/lang/python/2.7/patches/patch-configure_ac

35 lines
1 KiB
Text

SOVERSION defaults to 1.0. SHARED_LIBS, however, could be changed
at any point. Ensure they are on sync in case INSTSONAME is used
by a third party.
Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -479,7 +479,7 @@ esac
if test $define_xopen_source = yes
then
- AC_DEFINE(_XOPEN_SOURCE, 600,
+ AC_DEFINE(_XOPEN_SOURCE, 700,
Define to the level of X/Open that your system supports)
# On Tru64 Unix 4.0F, defining _XOPEN_SOURCE also requires
@@ -489,7 +489,7 @@ then
AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1,
Define to activate Unix95-and-earlier features)
- AC_DEFINE(_POSIX_C_SOURCE, 200112L, Define to activate features from IEEE Stds 1003.1-2001)
+ AC_DEFINE(_POSIX_C_SOURCE, 200809L, Define to activate features from IEEE Stds 1003.1-2001)
fi
@@ -930,6 +930,9 @@ if test $enable_shared = "yes"; then
case $ac_sys_system in
FreeBSD*)
SOVERSION=`echo $SOVERSION|cut -d "." -f 1`
+ ;;
+ OpenBSD*)
+ SOVERSION=${LIBpython2.7_VERSION}
;;
esac
INSTSONAME="$LDLIBRARY".$SOVERSION