ports/x11/vlc/patches/patch-modules_access_http_Makefile_am

14 lines
557 B
Text

Workaround for duplicate symbols from libcompat being linked twice.
Index: modules/access/http/Makefile.am
--- modules/access/http/Makefile.am.orig
+++ modules/access/http/Makefile.am
@@ -16,7 +16,7 @@ libvlc_http_la_SOURCES = \
access/http/connmgr.c access/http/connmgr.h
libvlc_http_la_CPPFLAGS = -Dneedsomethinghere
libvlc_http_la_LIBADD = \
- $(LTLIBVLCCORE) ../compat/libcompat.la \
+ $(LTLIBVLCCORE) \
$(SOCKET_LIBS) $(LIBPTHREAD)
#libvlc_http_la_LDFLAGS = -no-undefined -export-symbols-regex ^vlc_http_
#pkglib_LTLIBRARIES += libvlc_http.la