ports/net/tinyfugue/patches/patch-unix_tfconfig

50 lines
1.4 KiB
Text

--- unix/tfconfig.orig Sun Aug 11 22:53:07 2013
+++ unix/tfconfig Sun Aug 11 22:55:49 2013
@@ -223,17 +223,17 @@ fi
echo
echo 'To change these locations type "n" now and edit the unix/Config file.'
-while [ -z "$ans" ]; do
- echo 'Continue? (y/n)'
- read ans;
- case "$ans" in
- y|Y) break ;;
- n|N) exit 1 ;;
- *) ans=
- echo 'Please answer "y" or "n".'
- ;;
- esac
-done
+# while [ -z "$ans" ]; do
+# echo 'Continue? (y/n)'
+# read ans;
+# case "$ans" in
+# y|Y) break ;;
+# n|N) exit 1 ;;
+# *) ans=
+# echo 'Please answer "y" or "n".'
+# ;;
+# esac
+# done
echo; echo
rm -f ../src/Makefile ${AOUT}
@@ -561,6 +561,8 @@ int main() {
raise(0);
setlocale(0, "C");
sigaction(0, NULL, NULL);
+ arc4random();
+ arc4random_uniform(0);
srand(0);
srandom(0);
strcasecmp(NULL, NULL);
@@ -613,7 +615,8 @@ fi
for sym in \
bcopy bsearch bzero connect fileno getcwd gethostbyname getpwnam \
gettimeofday getwd h_errno hstrerror index kill memcpy memset raise \
- setlocale sigaction srand srandom strcasecmp strchr strcmpi strcspn \
+ setlocale sigaction arc4random arc4random_uniform srand srandom \
+ strcasecmp strchr strcmpi strcspn \
strerror strftime stricmp strstr strtod strtol tzset waitpid
do
if egrep "(^|[^a-z_])_?_?${sym}([^a-z]|\$)" symtest.out >/dev/null; then