20 lines
998 B
Text
20 lines
998 B
Text
Index: test/CMakeLists.txt
|
|
--- test/CMakeLists.txt.orig
|
|
+++ test/CMakeLists.txt
|
|
@@ -77,6 +77,7 @@ if(GLM_TEST_ENABLE_FAST_MATH)
|
|
|
|
if((CMAKE_CXX_COMPILER_ID MATCHES "Clang") OR (CMAKE_CXX_COMPILER_ID MATCHES "GNU"))
|
|
add_compile_options(-ffast-math)
|
|
+ add_definitions(-mfpmath=387)
|
|
|
|
elseif(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
|
|
add_compile_options(/fp:fast)
|
|
@@ -197,7 +198,7 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
|
|
message("GLM: Clang - ${CMAKE_CXX_COMPILER_ID} compiler")
|
|
endif()
|
|
|
|
- add_compile_options(-Werror -Weverything)
|
|
+ add_compile_options(-Weverything)
|
|
add_compile_options(-Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-c++11-long-long -Wno-padded -Wno-gnu-anonymous-struct -Wno-nested-anon-types)
|
|
add_compile_options(-Wno-undefined-reinterpret-cast -Wno-sign-conversion -Wno-unused-variable -Wno-missing-prototypes -Wno-unreachable-code -Wno-missing-variable-declarations -Wno-sign-compare -Wno-global-constructors -Wno-unused-macros -Wno-format-nonliteral)
|
|
|