17 lines
580 B
Text
17 lines
580 B
Text
fails with _XOPEN_SOURCE set;
|
|
|
|
/usr/include/c++/v1/__bsd_locale_fallbacks.h:123:17: error: use of undeclared identifier 'vasprintf'; did you mean 'vsprintf'?
|
|
int __res = vasprintf(__s, __format, __va);
|
|
|
|
Index: CMakeLists.txt
|
|
--- CMakeLists.txt.orig
|
|
+++ CMakeLists.txt
|
|
@@ -486,6 +486,8 @@ endif(BUILD_TESTING)
|
|
if(NOT WIN32)
|
|
if(CMAKE_SYSTEM MATCHES "SunOS.*")
|
|
add_definitions("-D_XOPEN_SOURCE=600")
|
|
+ elseif(CMAKE_SYSTEM MATCHES "OpenBSD.*")
|
|
+ # ...
|
|
else()
|
|
add_definitions("-D_XOPEN_SOURCE=700")
|
|
endif(CMAKE_SYSTEM MATCHES "SunOS.*")
|