14 lines
590 B
Text
14 lines
590 B
Text
from Fedora: gsoap-libtool.patch (creates shared libraries)
|
|
|
|
Index: gsoap/samples/autotest/Makefile.am
|
|
--- gsoap/samples/autotest/Makefile.am.orig
|
|
+++ gsoap/samples/autotest/Makefile.am
|
|
@@ -14,7 +14,7 @@ SOAP_FLAGS=-SL -T -I$(top_srcdir)/gsoap/import -I$(top
|
|
WSDLINPUT=$(top_srcdir)/gsoap/samples/autotest/examples.wsdl
|
|
SOAPHEADER=$(top_srcdir)/gsoap/samples/autotest/examples.h
|
|
SOAP_CPP_SRC=soapC.cpp soapServer.cpp
|
|
-SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.a
|
|
+SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.la
|
|
|
|
$(SOAP_CPP_SRC) : $(WSDLINPUT)
|
|
$(WSDL) $(WSDL_FLAGS) $(WSDLINPUT)
|