22 lines
1.2 KiB
Text
22 lines
1.2 KiB
Text
OpenBSD's file(1) doesn't support the --mime-encoding option, so remove
|
|
those checks as they cause the build to fail.
|
|
|
|
Index: src/Makefile.in
|
|
--- src/Makefile.in.orig
|
|
+++ src/Makefile.in
|
|
@@ -2290,15 +2290,7 @@ uninstall-am: uninstall-binPROGRAMS
|
|
|
|
infocontrib.h: $(srcdir)/buildtools/geninfocontrib_h.sh $(top_srcdir)/doc/vice.texi $(srcdir)/buildtools/infocontrib.sed
|
|
@echo "generating infocontrib.h"
|
|
- @if [ "`file --mime-encoding $(srcdir)/buildtools/geninfocontrib_h.sh`" != "$(srcdir)/buildtools/geninfocontrib_h.sh: iso-8859-1" ]; then \
|
|
- echo "ERROR: geninfocontrib_h.sh contains content that is not valid iso-8859-x" >&2; \
|
|
- false; \
|
|
- fi
|
|
@$(SHELL) $(srcdir)/buildtools/geninfocontrib_h.sh infocontrib.h <$(top_srcdir)/doc/vice.texi `grep "VICEDATE_YEAR " $(top_srcdir)/src/vicedate.h | cut -d " " -f 3` | LC_ALL=C sed -f $(srcdir)/buildtools/infocontrib.sed >infocontrib.h
|
|
- @if [ "`file --mime-encoding infocontrib.h`" != "infocontrib.h: iso-8859-1" ]; then \
|
|
- echo "ERROR: generated infocontrib.h contains content that is not valid iso-8859-x" >&2; \
|
|
- false; \
|
|
- fi
|
|
|
|
# we need to replace \ and space by "regular" characters, else things break on some shells
|
|
@LC_ALL=C sed -e 's/\\/{/g' -e 's/ /}/g' <$(top_srcdir)/README >./README.tmp
|