17 lines
548 B
Text
17 lines
548 B
Text
Index: configure.ac.in
|
|
--- configure.ac.in.orig
|
|
+++ configure.ac.in
|
|
@@ -432,10 +432,10 @@ fi
|
|
|
|
DATE=`date +"%Y-%m-%d"`
|
|
|
|
-if test -d "/usr/include/hiredis"; then
|
|
+if pkg-config --exists hiredis; then
|
|
AC_DEFINE_UNQUOTED(HAVE_HIREDIS, 1, [Local hiredis package present])
|
|
- HIREDIS_INC="`pkg-config --cflags hiredis` -I/usr/include/hiredis"
|
|
- HIREDIS_LIB="`pkg-config --libs hiredis` -lhiredis"
|
|
+ HIREDIS_INC="`pkg-config --cflags hiredis`"
|
|
+ HIREDIS_LIB="`pkg-config --libs hiredis`"
|
|
else
|
|
HIREDIS_INC="-I ${HERE}/third-party/hiredis"
|
|
fi
|