ports/emulators/spim/patches/patch-spim_Makefile

28 lines
810 B
Text

--- spim/Makefile.orig Sat Jan 9 06:22:57 2010
+++ spim/Makefile Mon Aug 20 16:55:19 2012
@@ -66,13 +66,13 @@ DOC_DIR = ../Documentation
# Full path for the directory that will hold the executable files:
-BIN_DIR = /usr/local/bin
+BIN_DIR = ${PREFIX}/bin
# Full path for the directory that will hold the exception handler:
-EXCEPTION_DIR = /usr/local/lib/spim
+EXCEPTION_DIR = ${PREFIX}/share/spim
# Full path for the directory that will hold the man files:
-MAN_DIR = /usr/local/man/en
+MAN_DIR = ${PREFIX}/man/man1
# If you have flex, use it instead of lex. If you use flex, define this
@@ -109,7 +109,7 @@ CFLAGS = -I. -I$(CPU_DIR) $(DEFINES) -g -Wall
YFLAGS = -d --file-prefix=y
YCFLAGS =
LDFLAGS = -lm
-CSH = bash
+CSH = sh
# lex.yy.c is usually compiled with -O to speed it up.