20 lines
851 B
Text
20 lines
851 B
Text
Index: CMakeLists.txt
|
|
--- CMakeLists.txt.orig
|
|
+++ CMakeLists.txt
|
|
@@ -197,7 +197,7 @@ if (APPLE)
|
|
endif ()
|
|
endif ()
|
|
|
|
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
|
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
|
|
find_package(PkgConfig REQUIRED)
|
|
|
|
if (CMAKE_VERSION VERSION_LESS "3.1")
|
|
@@ -607,7 +607,6 @@ elseif (SLIC3R_FHS)
|
|
DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${SIZE}x${SIZE}/apps RENAME PrusaSlicer-gcodeviewer.png
|
|
)
|
|
endforeach()
|
|
- install(DIRECTORY ${SLIC3R_RESOURCES_DIR}/udev/ DESTINATION lib/udev/rules.d)
|
|
else ()
|
|
install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/resources/applications)
|
|
install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/resources/applications)
|