ports/devel/libuv/patches/patch-CMakeLists_txt

44 lines
1.5 KiB
Text

Index: CMakeLists.txt
--- CMakeLists.txt.orig
+++ CMakeLists.txt
@@ -235,11 +235,11 @@ if(CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD")
list(APPEND uv_sources src/unix/freebsd.c)
endif()
-if(CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|NetBSD|OpenBSD")
+if(CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|NetBSD|OpenBSD|SecBSD")
list(APPEND uv_sources src/unix/posix-hrtime.c src/unix/bsd-proctitle.c)
endif()
-if(APPLE OR CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|NetBSD|OpenBSD")
+if(APPLE OR CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|NetBSD|OpenBSD|SecBSD")
list(APPEND uv_sources src/unix/bsd-ifaddrs.c src/unix/kqueue.c)
endif()
@@ -247,7 +247,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
list(APPEND uv_sources src/unix/random-getrandom.c)
endif()
-if(APPLE OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
+if(APPLE OR CMAKE_SYSTEM_NAME MATCHES "OpenBSD|SecBSD")
list(APPEND uv_sources src/unix/random-getentropy.c)
endif()
@@ -293,7 +293,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
list(APPEND uv_libraries kvm)
endif()
-if(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
+if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD|SecBSD")
list(APPEND uv_sources src/unix/openbsd.c)
endif()
@@ -384,7 +384,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "QNX")
list(APPEND uv_libraries socket)
endif()
-if(APPLE OR CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|Linux|NetBSD|OpenBSD")
+if(APPLE OR CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|Linux|NetBSD|OpenBSD|SecBSD")
list(APPEND uv_test_libraries util)
endif()