18 lines
667 B
Text
18 lines
667 B
Text
Don't forcefully enable RISC-V 'V'ector support, version 1.0 is neither
|
|
supported by clang 13 nor by our kernel.
|
|
|
|
Index: CMakeLists.txt
|
|
--- CMakeLists.txt.orig
|
|
+++ CMakeLists.txt
|
|
@@ -293,9 +293,9 @@ else()
|
|
# we add the gcv compiler flag, which then requires the CPU (now when using
|
|
# either compiler) to support V.
|
|
if(HWY_CMAKE_RVV)
|
|
- list(APPEND HWY_FLAGS -march=rv64gcv1p0)
|
|
+ #list(APPEND HWY_FLAGS -march=rv64gcv1p0)
|
|
if(${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")
|
|
- list(APPEND HWY_FLAGS -menable-experimental-extensions)
|
|
+ #list(APPEND HWY_FLAGS -menable-experimental-extensions)
|
|
endif()
|
|
endif()
|
|
endif()
|