ports/security/ssh-ldap-helper/patches/patch-configure_ac

15 lines
484 B
Text

Fix build with zlib 1.3
https://github.com/openssh/openssh-portable/commit/cb4ed12ffc332d1f72d054ed92655b5f1c38f621
Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -1323,7 +1323,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[
[[
int a=0, b=0, c=0, d=0, n, v;
n = sscanf(ZLIB_VERSION, "%d.%d.%d.%d", &a, &b, &c, &d);
- if (n != 3 && n != 4)
+ if (n < 1)
exit(1);
v = a*1000000 + b*10000 + c*100 + d;
fprintf(stderr, "found zlib version %s (%d)\n", ZLIB_VERSION, v);