57 lines
2.3 KiB
Text
57 lines
2.3 KiB
Text
Index: util/CMakeLists.txt
|
|
--- util/CMakeLists.txt.orig
|
|
+++ util/CMakeLists.txt
|
|
@@ -39,7 +39,7 @@ pkg_check_modules (GIO REQUIRED gio-2.0>=2.42)
|
|
pkg_check_modules (GNUTLS REQUIRED gnutls>=3.2.15)
|
|
|
|
# for uuidutils we need uuidlib
|
|
-pkg_check_modules (UUID REQUIRED uuid>=2.25.0)
|
|
+pkg_check_modules (UUID REQUIRED uuid>=1.46.2)
|
|
|
|
# for sshutils we need libssh
|
|
pkg_check_modules (LIBSSH REQUIRED libssh>=0.6.0)
|
|
@@ -56,30 +56,6 @@ pkg_check_modules (GPGME REQUIRED gpgme>=1.7.0)
|
|
# for serverutils we need libgcrypt
|
|
pkg_check_modules (GCRYPT REQUIRED libgcrypt)
|
|
|
|
-# for mqtt
|
|
-find_library(LIBPAHO paho-mqtt3c)
|
|
-message (STATUS "Looking for paho-mqtt3c ... ${LIBPAHO}")
|
|
-if (NOT LIBPAHO)
|
|
- message (SEND_ERROR "libpaho-mqtt3c is required for MQTTv5 support.")
|
|
-else (LIBPAHO)
|
|
- set (LIBPAHO_LDFLAGS "paho-mqtt3c")
|
|
- add_definitions (-DHAVE_MQTT=1)
|
|
-endif (NOT LIBPAHO)
|
|
-
|
|
-message (STATUS "Looking for libcrypt...")
|
|
-find_library (CRYPT crypt)
|
|
-message (STATUS "Looking for libcrypt... ${CRYPT}")
|
|
-if (NOT CRYPT)
|
|
-message (SEND_ERROR "The libcrypt library is required.")
|
|
-else (NOT CRYPT)
|
|
- pkg_search_module(CRYPT_M QUIET libcrypt)
|
|
- if (DEFINED ${CRYPT_M_VERSION} AND ${CRYPT_M_VERSION} VERSION_GREATER "3.1.1")
|
|
- message (STATUS "\t Using external crypt_gensal_r of ... ${CRYPT_M_VERSION}")
|
|
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DEXTERNAL_CRYPT_GENSALT_R=1")
|
|
- endif()
|
|
- set (CRYPT_LDFLAGS "-lcrypt")
|
|
-endif (NOT CRYPT)
|
|
-
|
|
option (BUILD_WITH_RADIUS "Try to build with Radius support" ON)
|
|
option (BUILD_WITH_LDAP "Try to build with LDAP support" ON)
|
|
|
|
@@ -124,11 +100,11 @@ include_directories (${GLIB_INCLUDE_DIRS} ${GPGME_INCL
|
|
${LIBXML2_INCLUDE_DIRS})
|
|
|
|
set (FILES passwordbasedauthentication.c compressutils.c fileutils.c gpgmeutils.c kb.c ldaputils.c
|
|
- nvticache.c mqtt.c radiusutils.c serverutils.c sshutils.c uuidutils.c
|
|
+ nvticache.c radiusutils.c serverutils.c sshutils.c uuidutils.c
|
|
xmlutils.c)
|
|
|
|
set (HEADERS passwordbasedauthentication.h authutils.h compressutils.h fileutils.h gpgmeutils.h kb.h
|
|
- ldaputils.h nvticache.h mqtt.h radiusutils.h serverutils.h sshutils.h
|
|
+ ldaputils.h nvticache.h radiusutils.h serverutils.h sshutils.h
|
|
uuidutils.h xmlutils.h)
|
|
|
|
if (BUILD_STATIC)
|