ports/security/cvechecker/patches/patch-configure_ac

19 lines
753 B
Text

Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -34,14 +34,12 @@ AC_CHECK_HEADERS([argp.h],,[AC_MSG_ERROR([argp.h heade
AC_CHECK_HEADERS([string.h],,[AC_MSG_ERROR([string.h header missing])])
# Checks for library functions.
-AC_CHECK_FUNCS([gethostname memset regcomp strchr strrchr strstr strlcpy],,
- [PKG_CHECK_MODULES([BSD], [libbsd])])
+AC_CHECK_FUNCS([gethostname memset regcomp strchr strrchr strstr strlcpy])
# Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_SIZE_T
AC_MSG_WARN([Please make sure pkg-config is installed and autoreconf run])
-PKG_CHECK_MODULES([BSD], [libbsd])
PKG_CHECK_MODULES([CONFIG], [libconfig >= 1.3])
CFLAGS="$CFLAGS $CONFIG_CFLAGS"
LIBS="$LIBS $CONFIG_LIBS $BSD_LIBS"