ports/net/isc-dhcp/patches/patch-client_Makefile_in

13 lines
584 B
Text

Index: client/Makefile.in
--- client/Makefile.in.orig
+++ client/Makefile.in
@@ -370,7 +370,8 @@ top_srcdir = @top_srcdir@
# production code. Sadly, we are not there yet.
SUBDIRS = . tests
AM_CPPFLAGS = -DCLIENT_PATH='"PATH=$(sbindir):/sbin:/bin:/usr/sbin:/usr/bin"' \
- -DLOCALSTATEDIR='"$(localstatedir)"'
+ -DLOCALSTATEDIR='"$(localstatedir)"' \
+ -D_PATH_DHCLIENT_SCRIPT='"$(sbindir)/dhclient-script"'
dist_sysconf_DATA = dhclient.conf.example
dhclient_SOURCES = client_tables.c clparse.c dhclient.c dhc6.c \
scripts/bsdos scripts/freebsd scripts/linux scripts/macos \