48 lines
1.6 KiB
Text
48 lines
1.6 KiB
Text
Index: configure.ac
|
|
--- configure.ac.orig
|
|
+++ configure.ac
|
|
@@ -108,25 +108,25 @@ PKG_CHECK_MODULES([sqlite], [sqlite3])
|
|
PKG_CHECK_MODULES([ssl], [libssl])
|
|
PKG_CHECK_MODULES([tinyxml], [tinyxml2 >= 8])
|
|
PKG_CHECK_MODULES([vmime], [vmime >= 0.9.2])
|
|
-AC_MSG_CHECKING([for vmime >= 0.9.2+git160])
|
|
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
|
- #include <string>
|
|
- #include <vmime/net/transport.hpp>
|
|
- #include <vmime/utility/inputStreamStringAdapter.hpp>
|
|
- int main() {
|
|
- using namespace vmime;
|
|
- using namespace vmime::net;
|
|
- std::string ct;
|
|
- utility::inputStreamStringAdapter ad(ct);
|
|
- mailbox mb;
|
|
- transport *xp;
|
|
- utility::progressListener *pr;
|
|
- xp->send(mb, mailboxList{}, ad, ct.size(), pr, mb, transport::sendOptions{});
|
|
- }
|
|
-])], [AC_MSG_RESULT([yes])], [
|
|
- AC_MSG_RESULT([no])
|
|
- AC_MSG_ERROR([vmime is still too old. See doc/install.rst.])
|
|
-])
|
|
+#AC_MSG_CHECKING([for vmime >= 0.9.2+git160])
|
|
+#AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
|
+# #include <string>
|
|
+# #include <vmime/net/transport.hpp>
|
|
+# #include <vmime/utility/inputStreamStringAdapter.hpp>
|
|
+# int main() {
|
|
+# using namespace vmime;
|
|
+# using namespace vmime::net;
|
|
+# std::string ct;
|
|
+# utility::inputStreamStringAdapter ad(ct);
|
|
+# mailbox mb;
|
|
+# transport *xp;
|
|
+# utility::progressListener *pr;
|
|
+# xp->send(mb, mailboxList{}, ad, ct.size(), pr, mb, transport::sendOptions{});
|
|
+# }
|
|
+#])], [AC_MSG_RESULT([yes])], [
|
|
+# AC_MSG_RESULT([no])
|
|
+# AC_MSG_ERROR([vmime is still too old. See doc/install.rst.])
|
|
+#])
|
|
PKG_CHECK_MODULES([xml2], [libxml-2.0])
|
|
PKG_CHECK_MODULES([xxhash], [libxxhash >= 0.7], [have_xxhash=1], [have_xxhash=0])
|
|
PKG_CHECK_MODULES([zlib], [zlib])
|