46 lines
1.6 KiB
Text
46 lines
1.6 KiB
Text
Disable fixincludes madness
|
|
|
|
Index: gcc/Makefile.in
|
|
--- gcc/Makefile.in.orig
|
|
+++ gcc/Makefile.in
|
|
@@ -263,9 +263,6 @@ endif
|
|
NO_PIE_CFLAGS = @NO_PIE_CFLAGS@
|
|
NO_PIE_FLAG = @NO_PIE_FLAG@
|
|
|
|
-# We don't want to compile the compilers with -fPIE, it make PCH fail.
|
|
-COMPILER += $(NO_PIE_CFLAGS)
|
|
-
|
|
# Link with -no-pie since we compile the compiler with -fno-PIE.
|
|
LINKER += $(NO_PIE_FLAG)
|
|
|
|
@@ -784,8 +781,6 @@ NO_PIE_FLAG_FOR_BUILD = @NO_PIE_FLAG_FOR_BUILD@
|
|
BUILD_CFLAGS= @BUILD_CFLAGS@ -DGENERATOR_FILE
|
|
BUILD_CXXFLAGS = @BUILD_CXXFLAGS@ -DGENERATOR_FILE
|
|
BUILD_NO_PIE_CFLAGS = @BUILD_NO_PIE_CFLAGS@
|
|
-BUILD_CFLAGS += $(BUILD_NO_PIE_CFLAGS)
|
|
-BUILD_CXXFLAGS += $(BUILD_NO_PIE_CFLAGS)
|
|
|
|
# Native compiler that we use. This may be C++ some day.
|
|
COMPILER_FOR_BUILD = $(CXX_FOR_BUILD)
|
|
@@ -2196,6 +2191,12 @@ DRIVER_DEFINES = \
|
|
CFLAGS-gcc.o += $(DRIVER_DEFINES) -DBASEVER=$(BASEVER_s)
|
|
gcc.o: $(BASEVER)
|
|
|
|
+ISCLANG = $(shell $(CC) --version | grep -c clang)
|
|
+
|
|
+ifeq ($(ISCLANG),1)
|
|
+CFLAGS-insn-attrtab.o += -fbracket-depth=512
|
|
+endif
|
|
+
|
|
specs.h : s-specs ; @true
|
|
s-specs : Makefile
|
|
lsf="$(lang_specs_files)"; for f in $$lsf; do \
|
|
@@ -3090,7 +3091,7 @@ stmp-fixinc: gsyslimits.h macro_list fixinc_list \
|
|
gcc_dir=`${PWD_COMMAND}` ; \
|
|
export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
|
|
cd $(build_objdir)/fixincludes && \
|
|
- $(SHELL) ./fixinc.sh "$${gcc_dir}/$${fix_dir}" \
|
|
+ $(SHELL) -c true "$${gcc_dir}/$${fix_dir}" \
|
|
$(BUILD_SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) ); \
|
|
rm -f $${fix_dir}/syslimits.h; \
|
|
if [ -f $${fix_dir}/limits.h ]; then \
|