ports/devel/check/patches/patch-doc_Makefile_in

69 lines
2.5 KiB
Text

Index: doc/Makefile.in
--- doc/Makefile.in.orig
+++ doc/Makefile.in
@@ -309,7 +309,7 @@ build_vendor = @build_vendor@
builddir = @builddir@
datadir = @datadir@
datarootdir = @datarootdir@
-docdir = $(datadir)/doc/$(PACKAGE)
+docdir = $(datadir)/doc/check/
dvidir = @dvidir@
exec_prefix = @exec_prefix@
host = @host@
@@ -947,47 +947,47 @@ $(srcdir)/check.texi: money.1-2.h.diff \
# diff returns 1 if there is a difference, but we don't want make to
# think that means there is an error
money.1-2.h.diff: $(eg_src)/money.1.h $(eg_src)/money.2.h
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 src/money.1.h src/money.2.h ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
money.1-3.c.diff: $(eg_src)/money.1.c $(eg_src)/money.3.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 src/money.1.c src/money.3.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
money.3-4.c.diff: $(eg_src)/money.3.c $(eg_src)/money.4.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 src/money.3.c src/money.4.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
money.4-5.c.diff: $(eg_src)/money.4.c $(eg_src)/money.5.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 src/money.4.c src/money.5.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
money.5-6.c.diff: $(eg_src)/money.5.c $(eg_src)/money.6.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 src/money.5.c src/money.6.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
check_money.1-2.c.diff: $(eg_tests)/check_money.1.c $(eg_tests)/check_money.2.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 tests/check_money.1.c tests/check_money.2.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
check_money.2-3.c.diff: $(eg_tests)/check_money.2.c $(eg_tests)/check_money.3.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 tests/check_money.2.c tests/check_money.3.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
check_money.3-6.c.diff: $(eg_tests)/check_money.3.c $(eg_tests)/check_money.6.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 tests/check_money.3.c tests/check_money.6.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;
check_money.6-7.c.diff: $(eg_tests)/check_money.6.c $(eg_tests)/check_money.7.c
- cd $(eg_root); \
+ -cd $(eg_root); \
diff -U 100 tests/check_money.6.c tests/check_money.7.c ${filter_timestapms} > @abs_builddir@/$@ || test $$? -eq 1; \
cd -;