40 lines
1.2 KiB
Text
40 lines
1.2 KiB
Text
only build manpage, and install it in correct dir
|
|
|
|
Index: doc/meson.build
|
|
--- doc/meson.build.orig
|
|
+++ doc/meson.build
|
|
@@ -1,31 +1,9 @@
|
|
-sphinx_output = custom_target(
|
|
- 'HTML documentation',
|
|
- output: 'html',
|
|
- input: ['index.rst', 'conf.py'],
|
|
- command: [sphinx, '-q', '-b', 'html', '-d', '@OUTDIR@/html_doctrees', meson.current_source_dir(), '@OUTPUT@'],
|
|
- build_by_default: true,
|
|
- install: true,
|
|
- install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
|
|
-)
|
|
-
|
|
custom_target(
|
|
- 'upload',
|
|
- input: sphinx_output,
|
|
- output: 'upload',
|
|
- build_always_stale: true,
|
|
- command: [
|
|
- 'rsync', '-vpruz', '--delete', '@INPUT@',
|
|
- 'www.musicpd.org:/var/www/mpd/doc/mpc/',
|
|
- '--chmod=a+rX',
|
|
- ],
|
|
-)
|
|
-
|
|
-custom_target(
|
|
'Manpage documentation',
|
|
- output: 'man',
|
|
+ output: 'man1',
|
|
input: ['index.rst', 'conf.py'],
|
|
- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
|
|
+ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@'],
|
|
build_by_default: true,
|
|
install: true,
|
|
- install_dir: get_option('datadir'),
|
|
+ install_dir: get_option('mandir'),
|
|
)
|