ports/math/cgal/patches/patch-CMakeLists_txt

31 lines
1 KiB
Text

- add workaround from https://bugs.kde.org/show_bug.cgi?id=304111
- Disable some dependencies
Index: CMakeLists.txt
--- CMakeLists.txt.orig
+++ CMakeLists.txt
@@ -391,6 +391,8 @@ include(${CGAL_MODULES_DIR}/CGAL_Macros.cmake)
include(${CGAL_MODULES_DIR}/CGAL_enable_end_of_configuration_hook.cmake)
cgal_setup_module_path()
+add_definitions ( -DBOOST_TT_HAS_OPERATOR_HPP_INCLUDED )
+
message( STATUS "CGAL_REFERENCE_CACHE_DIR=${CGAL_REFERENCE_CACHE_DIR}" )
if ( RUNNING_CGAL_AUTO_TEST )
@@ -1073,15 +1075,9 @@ if ( CGAL_BRANCH_BUILD )
message( "== Setting header checking ==" )
find_package(GMP REQUIRED)
- find_package(Doxygen REQUIRED)
find_package(Eigen3 REQUIRED)
find_package(Qt5 COMPONENTS Core Widgets Xml OpenGL Gui REQUIRED)
find_package(VTK COMPONENTS vtkImagingGeneral vtkIOImage NO_MODULE)
- find_package(IPE)
- find_package(RS3)
- find_package(LEDA)
- find_package(OpenMesh)
- find_package(OpenCV QUIET)
set(compile_options "\
${CMAKE_CXX_FLAGS} -DCGAL_EIGEN3_ENABLED -DCGAL_PROFILE \