13 lines
629 B
Text
13 lines
629 B
Text
Index: setup.py
|
|
--- setup.py.orig
|
|
+++ setup.py
|
|
@@ -82,9 +82,6 @@ if not any(arg in sys.argv for arg in ['clean', 'check
|
|
compiler_directives = {}
|
|
if 'CYTHON_TRACE' in sys.argv:
|
|
compiler_directives['linetrace'] = True
|
|
- # Set CFLAG to all optimizations (-O3), add `-g0` to reduce size of binaries, see #2276
|
|
- # Any additional CFLAGS will be appended. Only the last optimization flag will have effect
|
|
- os.environ['CFLAGS'] = '-O3 -g0 ' + os.environ.get('CFLAGS', '')
|
|
ext_modules = cythonize(
|
|
'pydantic/*.py',
|
|
exclude=['pydantic/generics.py'],
|