ports/mail/claws-mail/patches/patch-configure_ac

42 lines
1.6 KiB
Text

Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -629,13 +629,6 @@ dnl enchant is used for spell checking
AC_MSG_CHECKING([whether to use enchant])
AC_MSG_RESULT($enable_enchant)
if test $enable_enchant = yes; then
- PKG_CHECK_MODULES(ENCHANT, enchant >= 1.4.0,
- [
- AC_DEFINE(USE_ENCHANT, 1, enchant)
- echo "Building with enchant"
- enable_enchant=yes
- ],
- [
PKG_CHECK_MODULES(ENCHANT, enchant-2 >= 2.0.0,
[
AC_DEFINE(USE_ENCHANT, 1, enchant-2)
@@ -646,7 +639,6 @@ if test $enable_enchant = yes; then
echo "Building without enchant-notification"
enable_enchant=no
])
- ])
AC_SUBST(ENCHANT_CFLAGS)
AC_SUBST(ENCHANT_LIBS)
fi
@@ -833,6 +825,7 @@ if test x"$enable_alternate_addressbook" = xno; then
AC_CHECK_LIB(resolv, res_query, LDAP_LIBS="$LDAP_LIBS -lresolv")
AC_CHECK_LIB(socket, bind, LDAP_LIBS="$LDAP_LIBS -lsocket")
AC_CHECK_LIB(nsl, gethostbyaddr, LDAP_LIBS="$LDAP_LIBS -lnsl")
+ AC_CHECK_LIB(sasl2, sasl_version, LDAP_LIBS="$LDAP_LIBS -lsasl2")
AC_CHECK_LIB(lber, ber_get_tag, LDAP_LIBS="$LDAP_LIBS -llber",,
$LDAP_LIBS)
@@ -905,7 +898,7 @@ if test x"$enable_alternate_addressbook" = xno; then
AC_DEFINE(USE_JPILOT, 1, Define if you want JPilot support in addressbook.) ])
fi
- AC_CHECK_LIB(pisock, unpack_Address, [JPILOT_LIBS="-lpisock"], [JPILOT_LIBS="" enable_jpilot="no"])
+ AC_CHECK_LIB(pisock, unpack_Address, [JPILOT_LIBS="-lpisock -pthread"], [JPILOT_LIBS="" enable_jpilot="no"], -pthread)
if test x"$enable_jpilot" = xyes; then
AC_DEFINE(USE_JPILOT, 1, Define if you want JPilot support in addressbook.)
else