29 lines
1.3 KiB
Text
29 lines
1.3 KiB
Text
Index: Makefile
|
|
--- Makefile.orig
|
|
+++ Makefile
|
|
@@ -195,7 +195,7 @@ $(BUILDS): $(OUTDIR)/Makefile.$$(basename $$@)
|
|
@$(MAKE) -C "$(OUTDIR)" -f Makefile.$(basename $@) \
|
|
CXX="$(CXX)" LINK="$(LINK)" \
|
|
BUILDTYPE=$(shell echo $(subst .,,$(suffix $@)) | \
|
|
- python -c "print raw_input().capitalize()") \
|
|
+ python -c "print(input().capitalize())") \
|
|
builddir="$(shell pwd)/$(OUTDIR)/$@"
|
|
|
|
native: $(OUTDIR)/Makefile.native
|
|
@@ -266,14 +266,14 @@ clean: $(addsuffix .clean, $(ARCHES) $(ANDROID_ARCHES)
|
|
OUT_MAKEFILES = $(addprefix $(OUTDIR)/Makefile.,$(ARCHES))
|
|
$(OUT_MAKEFILES): $(GYPFILES) $(ENVFILE)
|
|
GYP_GENERATORS=make \
|
|
- build/gyp/gyp --generator-output="$(OUTDIR)" build/all.gyp \
|
|
+ gyp --generator-output="$(OUTDIR)" build/all.gyp \
|
|
-Ibuild/standalone.gypi --depth=. \
|
|
-Dv8_target_arch=$(subst .,,$(suffix $@)) \
|
|
-S.$(subst .,,$(suffix $@)) $(GYPFLAGS)
|
|
|
|
$(OUTDIR)/Makefile.native: $(GYPFILES) $(ENVFILE)
|
|
GYP_GENERATORS=make \
|
|
- build/gyp/gyp --generator-output="$(OUTDIR)" build/all.gyp \
|
|
+ gyp --generator-output="$(OUTDIR)" build/all.gyp \
|
|
-Ibuild/standalone.gypi --depth=. -S.native $(GYPFLAGS)
|
|
|
|
must-set-ANDROID_NDK_ROOT_OR_TOOLCHAIN:
|