ports/databases/postgresql-previous/patches/patch-src_interfaces_ecpg_ecpglib_Makefile

14 lines
529 B
Text

Index: src/interfaces/ecpg/ecpglib/Makefile
--- src/interfaces/ecpg/ecpglib/Makefile.orig
+++ src/interfaces/ecpg/ecpglib/Makefile
@@ -15,8 +15,8 @@ include $(top_builddir)/src/Makefile.global
PGFILEDESC = "ECPG - embedded SQL in C"
NAME= ecpg
-SO_MAJOR_VERSION= 6
-SO_MINOR_VERSION= $(MAJORVERSION)
+SO_MAJOR_VERSION= ${LIBecpg_MAJOR}
+SO_MINOR_VERSION= ${LIBecpg_MINOR}
override CPPFLAGS := -I../include -I$(top_srcdir)/src/interfaces/ecpg/include \
-I$(libpq_srcdir) -I$(top_builddir)/src/port -DFRONTEND $(CPPFLAGS)