109 lines
3.8 KiB
Text
109 lines
3.8 KiB
Text
#1: Set ports library version
|
|
#2: Don't pick up an installed linux/e2fsprogs libuuid.so
|
|
#3: llvm-ar (used for LTO) is installed as ar
|
|
#4: OpenBSD isn't multi-arch
|
|
#5: Try only the right tcl/tk string
|
|
|
|
Index: configure.ac
|
|
--- configure.ac.orig
|
|
+++ configure.ac
|
|
@@ -251,7 +251,7 @@ VERSION=PYTHON_VERSION
|
|
|
|
# Version number of Python's own shared library file.
|
|
AC_SUBST([SOVERSION])
|
|
-SOVERSION=1.0
|
|
+SOVERSION=0.0
|
|
|
|
# The later definition of _XOPEN_SOURCE and _POSIX_C_SOURCE disables
|
|
# certain features on NetBSD, so we need _NETBSD_SOURCE to re-enable
|
|
@@ -651,7 +651,7 @@ case $ac_sys_system/$ac_sys_release in
|
|
AC_DEFINE([_BSD_SOURCE], [1],
|
|
[Define on OpenBSD to activate all library features])
|
|
;;
|
|
- OpenBSD/*)
|
|
+ OpenBSD/*|SecBSD/*)
|
|
# OpenBSD undoes our definition of __BSD_VISIBLE if _XOPEN_SOURCE is
|
|
# also defined. This can be overridden by defining _BSD_SOURCE
|
|
# As this has a different meaning on Linux, only define it on OpenBSD
|
|
@@ -1123,6 +1123,8 @@ AC_MSG_CHECKING([for multiarch])
|
|
AS_CASE([$ac_sys_system],
|
|
[Darwin*], [MULTIARCH=""],
|
|
[FreeBSD*], [MULTIARCH=""],
|
|
+ [OpenBSD*], [MULTIARCH=""],
|
|
+ [SecBSD*], [MULTIARCH=""],
|
|
[MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
|
|
)
|
|
AC_SUBST([MULTIARCH])
|
|
@@ -1517,7 +1519,7 @@ if test $enable_shared = "yes"; then
|
|
PY3LIBRARY=libpython3.so
|
|
fi
|
|
;;
|
|
- Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|VxWorks*)
|
|
+ Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|SecBSD*|VxWorks*)
|
|
LDLIBRARY='libpython$(LDVERSION).so'
|
|
BLDLIBRARY='-L. -lpython$(LDVERSION)'
|
|
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
|
@@ -1858,13 +1860,13 @@ esac
|
|
[AC_MSG_RESULT([no])])
|
|
if test "$Py_LTO" = 'true' ; then
|
|
case $CC in
|
|
- *clang*)
|
|
+ *clang*|cc)
|
|
LDFLAGS_NOLTO="-fno-lto"
|
|
dnl Clang linker requires -flto in order to link objects with LTO information.
|
|
dnl Thin LTO is faster and works for object files with full LTO information, too.
|
|
AX_CHECK_COMPILE_FLAG([-flto=thin],[LDFLAGS_NOLTO="-flto=thin"],[LDFLAGS_NOLTO="-flto"])
|
|
AC_SUBST([LLVM_AR])
|
|
- AC_PATH_TOOL([LLVM_AR], [llvm-ar], [''], [${llvm_path}])
|
|
+ AC_PATH_TOOL([LLVM_AR], [ar], [''], [${llvm_path}])
|
|
AC_SUBST([LLVM_AR_FOUND])
|
|
if test -n "${LLVM_AR}" -a -x "${LLVM_AR}"
|
|
then
|
|
@@ -1987,7 +1989,7 @@ then
|
|
fi
|
|
LLVM_PROF_ERR=no
|
|
case $CC in
|
|
- *clang*)
|
|
+ *clang*|cc)
|
|
# Any changes made here should be reflected in the GCC+Darwin case below
|
|
PGO_PROF_GEN_FLAG="-fprofile-instr-generate"
|
|
PGO_PROF_USE_FLAG="-fprofile-instr-use=\"\$(shell pwd)/code.profclangd\""
|
|
@@ -3373,7 +3375,7 @@ then
|
|
else
|
|
LDSHARED="ld -Bshareable"
|
|
fi;;
|
|
- OpenBSD*)
|
|
+ OpenBSD*|SecBSD*)
|
|
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
|
then
|
|
LDSHARED='$(CC) -shared $(CCSHARED)'
|
|
@@ -3449,7 +3451,7 @@ then
|
|
AS_VAR_IF([enable_wasm_dynamic_linking], [yes], [
|
|
CCSHARED="-fPIC"
|
|
]);;
|
|
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*) CCSHARED="-fPIC";;
|
|
+ FreeBSD*|NetBSD*|OpenBSD*|SecBSD*|DragonFly*) CCSHARED="-fPIC";;
|
|
Haiku*) CCSHARED="-fPIC";;
|
|
OpenUNIX*|UnixWare*)
|
|
if test "$GCC" = "yes"
|
|
@@ -3506,7 +3508,7 @@ then
|
|
OpenUNIX*|UnixWare*) LINKFORSHARED="-Wl,-Bexport";;
|
|
SCO_SV*) LINKFORSHARED="-Wl,-Bexport";;
|
|
ReliantUNIX*) LINKFORSHARED="-W1 -Blargedynsym";;
|
|
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*)
|
|
+ FreeBSD*|NetBSD*|OpenBSD*|SecBSD*|DragonFly*)
|
|
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
|
then
|
|
LINKFORSHARED="-Wl,--export-dynamic"
|
|
@@ -4128,11 +4130,7 @@ dnl Detect Tcl/Tk. Use pkg-config if available.
|
|
dnl
|
|
found_tcltk=no
|
|
for _QUERY in \
|
|
- "tcl >= 8.5.12 tk >= 8.5.12" \
|
|
- "tcl8.6 tk8.6" \
|
|
"tcl86 tk86" \
|
|
- "tcl8.5 >= 8.5.12 tk8.5 >= 8.5.12" \
|
|
- "tcl85 >= 8.5.12 tk85 >= 8.5.12" \
|
|
; do
|
|
PKG_CHECK_EXISTS([$_QUERY], [
|
|
PKG_CHECK_MODULES([TCLTK], [$_QUERY], [found_tcltk=yes], [found_tcltk=no])
|