26 lines
922 B
Text
26 lines
922 B
Text
Revert..
|
|
|
|
[PATCH] configure: simplify creation of plugin symbol list
|
|
37650689473c4cdb5838f90cbc1aefbcd9332fb0
|
|
|
|
Index: plugins/meson.build
|
|
--- plugins/meson.build.orig
|
|
+++ plugins/meson.build
|
|
@@ -1,15 +1,8 @@
|
|
plugin_ldflags = []
|
|
# Modules need more symbols than just those in plugins/qemu-plugins.symbols
|
|
if not enable_modules
|
|
- if targetos == 'darwin'
|
|
- configure_file(
|
|
- input: files('qemu-plugins.symbols'),
|
|
- output: 'qemu-plugins-ld64.symbols',
|
|
- capture: true,
|
|
- command: ['sed', '-ne', 's/^[[:space:]]*\\(qemu_.*\\);/_\\1/p', '@INPUT@'])
|
|
- plugin_ldflags = ['-Wl,-exported_symbols_list,plugins/qemu-plugins-ld64.symbols']
|
|
- else
|
|
- plugin_ldflags = ['-Xlinker', '--dynamic-list=' + (meson.project_source_root() / 'plugins/qemu-plugins.symbols')]
|
|
+ if 'CONFIG_HAS_LD_DYNAMIC_LIST' in config_host
|
|
+ plugin_ldflags = ['-Wl,--dynamic-list=qemu-plugins-ld.symbols']
|
|
endif
|
|
endif
|
|
|