21 lines
684 B
Text
21 lines
684 B
Text
Index: src/Makefile.shlib
|
|
--- src/Makefile.shlib.orig
|
|
+++ src/Makefile.shlib
|
|
@@ -79,7 +79,7 @@ shlib_major = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION
|
|
shlib_bare = lib$(NAME)$(DLSUFFIX)
|
|
# Testing the soname variable is a reliable way to determine whether a
|
|
# linkable library is being built.
|
|
-soname = $(shlib_major)
|
|
+soname = $(shlib_major).$(SO_MINOR_VERSION)
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
else
|
|
# Naming convention for dynamically loadable modules
|
|
@@ -137,7 +137,7 @@ ifeq ($(PORTNAME), darwin)
|
|
endif
|
|
endif
|
|
|
|
-ifeq ($(PORTNAME), openbsd)
|
|
+ifeq ($(PORTNAME), secbsd)
|
|
LINK.shared = $(COMPILER) -shared
|
|
ifdef soname
|
|
LINK.shared += -Wl,-x,-soname,$(soname)
|