ports/security/exploitdb/Makefile

35 lines
771 B
Makefile

COMMENT= archive of public exploits and shellcode
VERSION= 2024-06-08
DISTNAME= exploitdb-${VERSION}
PKGNAME= exploitdb-${VERSION:S,-,,g}
CATEGORIES= security
HOMEPAGE= https://gitlab.com/exploit-database/exploitdb
MAINTAINER= Purple Rain <purplerain@secbsd.org>
SITES= ${HOMEPAGE}/-/archive/${VERSION}/
# GPLv2
PERMIT_PACKAGE= Yes
RUN_DEPENDS+= shells/bash
NO_BUILD= Yes
NO_TEST= Yes
pre-configure:
${SUBST_CMD} ${WRKSRC}/searchsploit \
${WRKSRC}/.searchsploit_rc
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share
${INSTALL_PROGRAM_DIR} ${PREFIX}/bin
cp -R ${WRKSRC}/ ${PREFIX}/share/exploitdb
mv ${PREFIX}/share/exploitdb/searchsploit \
${PREFIX}/bin/searchsploit
rm ${PREFIX}/share/exploitdb/{.,}*{.beforesubst,${PATCHORIG}}
.include <bsd.port.mk>