UPDATE: mail/mlmmj 1.4.3 -> 1.4.4
This commit is contained in:
parent
8363c894ed
commit
f6125da99c
4 changed files with 23 additions and 29 deletions
|
@ -1,6 +1,6 @@
|
|||
COMMENT= mailing list manager
|
||||
|
||||
DISTNAME= mlmmj-1.4.3
|
||||
DISTNAME= mlmmj-1.4.4
|
||||
|
||||
CATEGORIES= mail
|
||||
|
||||
|
@ -20,7 +20,7 @@ LIB_DEPENDS= converters/libiconv \
|
|||
|
||||
WANTLIB+= c iconv
|
||||
|
||||
DISTFILES= RELEASE_1_4_3${EXTRACT_SUFX}
|
||||
DISTFILES= RELEASE_1_4_4${EXTRACT_SUFX}
|
||||
EXTRACT_SUFX= .tar.gz
|
||||
|
||||
WRKSRC= ${WRKDIR}/mlmmj
|
||||
|
@ -36,6 +36,11 @@ CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include -I${WRKSRC}/include" \
|
|||
post-extract:
|
||||
cd ${WRKSRC}; ${AUTOCONF_ENV} autoreconf -fi
|
||||
|
||||
NO_TEST= Yes
|
||||
DOCS= README* TUNABLES
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/mlmmj
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${PREFIX}/share/doc/mlmmj
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} contrib/receivestrip/README \
|
||||
${PREFIX}/share/doc/mlmmj/README.receive-strip
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (RELEASE_1_4_3.tar.gz) = hthGW+KQv5tQ0ehkTeIJsqWzWk/KNbzX0s2bNJ+ucN8=
|
||||
SIZE (RELEASE_1_4_3.tar.gz) = 280649
|
||||
SHA256 (RELEASE_1_4_4.tar.gz) = rhr+edNESJHIi+YocNHJJms6GQoX4jQM2jLheE82F3E=
|
||||
SIZE (RELEASE_1_4_4.tar.gz) = 281135
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
Fix build with "-fno-common", from FreeBSD.
|
||||
https://gitlab.com/mlmmj/mlmmj/-/merge_requests/2
|
||||
|
||||
Index: include/mlmmj.h
|
||||
--- include/mlmmj.h.orig
|
||||
+++ include/mlmmj.h
|
||||
@@ -81,7 +81,7 @@ enum subtype {
|
||||
SUB_NONE /* For when an address is not subscribed at all */
|
||||
};
|
||||
|
||||
-char *subtype_strs[7]; /* count matches enum above; defined in subscriberfuncs.c */
|
||||
+extern char *subtype_strs[7]; /* count matches enum above; defined in subscriberfuncs.c */
|
||||
|
||||
enum subreason {
|
||||
SUB_REQUEST,
|
||||
@@ -92,7 +92,7 @@ enum subreason {
|
||||
SUB_SWITCH
|
||||
};
|
||||
|
||||
-char * subreason_strs[6]; /* count matches enum above; defined in subscriberfuncs.c */
|
||||
+extern char * subreason_strs[6]; /* count matches enum above; defined in subscriberfuncs.c */
|
||||
|
||||
void print_version(const char *prg);
|
||||
|
|
@ -18,6 +18,19 @@ bin/mlmmj-recieve
|
|||
@man man/man1/mlmmj-send.1
|
||||
@man man/man1/mlmmj-sub.1
|
||||
@man man/man1/mlmmj-unsub.1
|
||||
share/doc/mlmmj/
|
||||
share/doc/mlmmj/README
|
||||
share/doc/mlmmj/README.access
|
||||
share/doc/mlmmj/README.archives
|
||||
share/doc/mlmmj/README.exim4
|
||||
share/doc/mlmmj/README.footers
|
||||
share/doc/mlmmj/README.listtexts
|
||||
share/doc/mlmmj/README.postfix
|
||||
share/doc/mlmmj/README.qmail
|
||||
share/doc/mlmmj/README.receive-strip
|
||||
share/doc/mlmmj/README.security
|
||||
share/doc/mlmmj/README.sendmail
|
||||
share/doc/mlmmj/TUNABLES
|
||||
share/mlmmj/
|
||||
share/mlmmj/text.skel/
|
||||
share/mlmmj/text.skel/ast/
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue