sync ports with The Matrix
This commit is contained in:
parent
ec769495ab
commit
f5034afcba
3108 changed files with 91999 additions and 80269 deletions
|
@ -1,6 +1,6 @@
|
|||
COMMENT = build and package Ruby extensions using Rake as glue
|
||||
|
||||
DISTNAME = rake-compiler-1.2.0
|
||||
DISTNAME = rake-compiler-1.2.5
|
||||
CATEGORIES = devel
|
||||
|
||||
HOMEPAGE = https://github.com/rake-compiler/rake-compiler
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (rake-compiler-1.2.0.gem) = 4CvPVtLz2Ay4eLdgJo6PE9yOQlHJ+6CA3td5sWeub/U=
|
||||
SIZE (rake-compiler-1.2.0.gem) = 38912
|
||||
SHA256 (rake-compiler-1.2.5.gem) = q5sDpttfzoj7jc/yPAyuO8zXFm8DbH/IshmfU+44sqw=
|
||||
SIZE (rake-compiler-1.2.5.gem) = 35328
|
||||
|
|
|
@ -8,18 +8,15 @@ created can use BSD make extensions.
|
|||
Index: lib/rake/extensiontask.rb
|
||||
--- lib/rake/extensiontask.rb.orig
|
||||
+++ lib/rake/extensiontask.rb
|
||||
@@ -157,7 +157,9 @@ module Rake
|
||||
task "copy:#{@name}:#{platf}:#{ruby_ver}" => [lib_path, tmp_binary_path, "#{tmp_path}/Makefile"] do
|
||||
# install in lib for native platform only
|
||||
unless for_platform
|
||||
- sh "#{make} install target_prefix=", chdir: tmp_path
|
||||
+ command = "#{make} install target_prefix="
|
||||
+ command += " INSTALL_PROG='/usr/bin/install -c -m 0755'" unless Process.uid == 0
|
||||
+ sh command, chdir: tmp_path
|
||||
end
|
||||
end
|
||||
# copy binary from temporary location to staging directory
|
||||
@@ -502,20 +504,7 @@ Java extension should be preferred.
|
||||
@@ -169,6 +169,7 @@ module Rake
|
||||
make_command_line << "install"
|
||||
make_command_line << "sitearchdir=#{relative_lib_path}"
|
||||
make_command_line << "sitelibdir=#{relative_lib_path}"
|
||||
+ make_command_line << "INSTALL_PROG=/usr/bin/install -c -m 0755" unless Process.uid == 0
|
||||
make_command_line << "target_prefix="
|
||||
|
||||
sh(*make_command_line, chdir: tmp_path)
|
||||
@@ -494,20 +495,7 @@ Java extension should be preferred.
|
||||
end
|
||||
|
||||
def make
|
||||
|
|
|
@ -34,18 +34,10 @@ ${GEM_LIB}/gems/${DISTNAME}/features/support/platform_extension_helpers.rb
|
|||
${GEM_LIB}/gems/${DISTNAME}/lib/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/rake/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/rake/baseextensiontask.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/rake/compiler_config.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/rake/extensioncompiler.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/rake/extensiontask.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/rake/javaextensiontask.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/lib/
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/lib/rake/
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/lib/rake/extensiontask_spec.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/lib/rake/javaextensiontask_spec.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/spec.opts
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/spec_helper.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/support/
|
||||
${GEM_LIB}/gems/${DISTNAME}/spec/support/capture_output_helper.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/tasks/
|
||||
${GEM_LIB}/gems/${DISTNAME}/tasks/bin/
|
||||
${GEM_LIB}/gems/${DISTNAME}/tasks/bin/cross-ruby.rake
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue