sync ports with The Matrix
This commit is contained in:
parent
ec769495ab
commit
f5034afcba
3108 changed files with 91999 additions and 80269 deletions
|
@ -1,21 +1,20 @@
|
|||
COMMENT= visitor-style traversal of Perl data structures
|
||||
COMMENT = visitor-style traversal of Perl data structures
|
||||
|
||||
MODULES= cpan
|
||||
PKG_ARCH= *
|
||||
DISTNAME= Data-Visitor-0.30
|
||||
CATEGORIES= devel
|
||||
REVISION= 0
|
||||
DISTNAME = Data-Visitor-0.32
|
||||
FIX_EXTRACT_PERMISSIONS = Yes
|
||||
|
||||
# perl
|
||||
PERMIT_PACKAGE= Yes
|
||||
CATEGORIES = devel
|
||||
|
||||
RUN_DEPENDS= devel/p5-Class-Load>=0.06 \
|
||||
devel/p5-Moose>=0.89 \
|
||||
devel/p5-Task-Weaken \
|
||||
devel/p5-Tie-ToObject>=0.01 \
|
||||
devel/p5-namespace-clean>=0.19
|
||||
# Perl
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
TEST_DEPENDS= devel/p5-Test-Requires \
|
||||
devel/p5-Test-Script>=1.05
|
||||
MODULES = cpan
|
||||
|
||||
RUN_DEPENDS = devel/p5-Moose>=0.89 \
|
||||
devel/p5-Tie-ToObject>=0.01 \
|
||||
devel/p5-namespace-clean>=0.19
|
||||
TEST_DEPENDS = devel/p5-Test-Needs
|
||||
|
||||
PKG_ARCH = *
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (Data-Visitor-0.30.tar.gz) = jqJKvMNlnnYKqUruK6fdVMrK8gMCcFUkFD85VUAJ7VQ=
|
||||
SIZE (Data-Visitor-0.30.tar.gz) = 24542
|
||||
SHA256 (Data-Visitor-0.32.tar.gz) = sZQpDyV8xidaA5N0ERVUxmahZQ5MAa15nB4KJ39HkX0=
|
||||
SIZE (Data-Visitor-0.32.tar.gz) = 39313
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Data::Alias is broken with Perl 5.24.1, do not use it.
|
||||
https://rt.cpan.org/Public/Bug/Display.html?id=118854
|
||||
|
||||
Index: lib/Data/Visitor.pm
|
||||
--- lib/Data/Visitor.pm.orig
|
||||
+++ lib/Data/Visitor.pm
|
||||
@@ -22,7 +22,7 @@ use namespace::clean -except => 'meta';
|
||||
# the double not makes this no longer undef, so exempt from useless constant warnings in older perls
|
||||
use constant DEBUG => not not our $DEBUG || $ENV{DATA_VISITOR_DEBUG};
|
||||
|
||||
-use constant HAS_DATA_ALIAS => load_optional_class('Data::Alias');
|
||||
+use constant HAS_DATA_ALIAS => 0;
|
||||
|
||||
has tied_as_objects => (
|
||||
isa => "Bool",
|
|
@ -1,12 +0,0 @@
|
|||
Index: t/weak.t
|
||||
--- t/weak.t.orig
|
||||
+++ t/weak.t
|
||||
@@ -3,7 +3,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
|
||||
-use Test::More;
|
||||
+use Test::More skip_all => 'Data::Alias is broken';
|
||||
|
||||
use Test::Requires 'Data::Alias';
|
||||
|
Loading…
Add table
Add a link
Reference in a new issue