UPDATE: devel/apr 1.7.2 -> 1.7.5

This commit is contained in:
purplerain 2025-01-26 19:04:24 +00:00
parent 542bf9b6dd
commit ec9dec921a
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
5 changed files with 10 additions and 25 deletions

View file

@ -1,8 +1,9 @@
COMMENT= Apache Portable Runtime
V= 1.7.2
V= 1.7.5
REVISION= 0
DISTNAME= apr-$V
SHARED_LIBS += apr-1 7.1 # .6.2
SHARED_LIBS += apr-1 7.2 # .6.2
CATEGORIES= devel
@ -17,7 +18,7 @@ WANTLIB += pthread
SITES= ${SITE_APACHE:=apr/}
AUTOCONF_VERSION=2.71
AUTOCONF_VERSION=2.72
CONFIGURE_STYLE=autoconf autoheader
# Prevent APR pools from re-using dynamic memory allocations:
CFLAGS += "-DAPR_ALLOCATOR_MAX_FREE_DEFAULT=1"

View file

@ -1,2 +1,2 @@
SHA256 (apr-1.7.2.tar.gz) = PYmZshb3tiNTQ6Tj1FbOk3mqmjgP+zCFEvEz8MXrLbk=
SIZE (apr-1.7.2.tar.gz) = 1115676
SHA256 (apr-1.7.5.tar.gz) = M3X6Nl1nvPlF5StSy6B6vqV+9TD0Cygf++l3qSUTYds=
SIZE (apr-1.7.5.tar.gz) = 1131871

View file

@ -1,7 +1,7 @@
Index: apr-config.in
--- apr-config.in.orig
+++ apr-config.in
@@ -243,13 +243,7 @@ while test $# -gt 0; do
@@ -258,13 +258,7 @@ while test $# -gt 0; do
exit 0
;;
--apr-libtool)

View file

@ -1,7 +1,7 @@
Index: configure.in
--- configure.in.orig
+++ configure.in
@@ -1585,6 +1585,10 @@ case $host in
@@ -1622,6 +1622,10 @@ case $host in
*)
AC_CHECK_FUNCS(mkstemp)
;;
@ -12,7 +12,7 @@ Index: configure.in
esac
AC_SUBST(fork)
@@ -2098,6 +2102,14 @@ elif test "$ac_cv_type_off_t" = "yes"; then
@@ -2135,6 +2139,14 @@ elif test "$ac_cv_type_off_t" = "yes"; then
*)
AC_ERROR([could not determine the size of off_t])
;;
@ -27,7 +27,7 @@ Index: configure.in
esac
])])])])
else
@@ -2466,7 +2478,7 @@ APR_IFALLYES(header:semaphore.h func:sem_open func:sem
@@ -2503,7 +2515,7 @@ APR_IFALLYES(header:semaphore.h func:sem_open func:sem
func:sem_unlink func:sem_post func:sem_wait,
hasposixser="1", hasposixser="0")
APR_IFALLYES(func:semget func:semctl func:semop define:SEM_UNDO,

View file

@ -10,19 +10,3 @@ Index: network_io/unix/sockets.c
if (apr_is_option_set(sock, APR_SO_NONBLOCK) == 1) {
apr_set_option(*new, APR_SO_NONBLOCK, 1);
}
@@ -388,6 +388,15 @@ apr_status_t apr_socket_accept(apr_socket_t **new, apr
apr_status_t apr_socket_connect(apr_socket_t *sock, apr_sockaddr_t *sa)
{
int rc;
+/*
+ * OpenBSD doesn't support connect() to INADDR_ANY so convert to
+ * INADDR_LOOPBACK to emulate what is expected.
+ */
+#ifdef __OpenBSD__
+ if (sa->family == APR_INET)
+ if (sa->sa.sin.sin_addr.s_addr == INADDR_ANY)
+ sa->sa.sin.sin_addr.s_addr = htonl(INADDR_LOOPBACK);
+#endif
do {
rc = connect(sock->socketdes,